Home / Forum / Software / Estlcam z movement problem / Reply To: Estlcam z movement problem

Profile photo of MarcoMarco
Post count: 18
#10116 |

I’m having some issues for milling holes in the bed of MPCNC for the captive nuts, to screw the bed-clamps. I’ve started with a matrix of 4 x 4 holes but after some trouble now I’m trying with a single hole. The spinde drills a hole of 6 mm diameter and 22mm of deep and then mills a concentric shape of 11 mm of diameter and 5 mm of deep for the nut. While drilling, the burr goes down and then lifts (1 mm of depth every pass), after reached 22mm of depth it should rise up at level z=0 and mill the housing for the nut. However, sometimes after completing the 6mmx22mm hole, the spindle doesn’t rise up entirely and mills (with some alarming noise) the 11 mm diameter hole with a deep of 19-20 mm.
The gcode should be OK because sometimes the job goes fine and in simulation all works. I’ve changed G0 code with G1 in the setup of Estlcam (I’ve bought it) as suggested by Christian, I’ve slow down z movement in Estlcam (2 mm/sec during milling) and Marlin (MAx feedrate 6, Max acceleration 25). There’s some setting for “rapid” Z that I’ve not considered?