Home / Forum / Software / ESTLCAM / Reply To: ESTLCAM

Profile photo of UnLtdSoulUnLtdSoul
Post count: 9
#12809 |

I installed what i believe is the latest Estlcam version (8.505), but there seems to be some ‘bugs’ regarding gcode Marlin output. OR maybe I simply don’t have the settings correct?

Here is what I see:
I have simple 2.5 D dfx line drawings where i am cutting out pieces –
The gcode Estlcam created – where i see are issues – have to do with movement Speed when it switches between the XY axis and Z axis movements
Here are snippets of the code as it created it:

;Project BoardW1x8_TB
;Created by Estlcam version 8 build 8.505
;Machining time about 12:04:48 AM hours

;M03 S24000
G00 X0.0000 Y0.0000 Z0.0000
[// I use limit switches, and after I home all axis I move the spindle to the start location and i change this line to:
G92 X0 Y0 Z0 ]

G00 Z5.0000

;No. 1: Cutout 1
G00 X198.0864 Y-6.8200
;// NOTE G00 is ‘rapid movement’ To move the head/spindle to new location without cutting (/printing)
no mm/min speed is given for the G00 commands in Estlcam, but, Marlin seems to need them to be given.
When the MPCNC with Marlin firmware gets the G00 before any speed has been declared the movement is excruciatingly slow

G00 Z0.5000
G01 Z-7.0000 F300 S24000
G01 X104.7800 F1200
;NOTE on the G01 command Estlcam sets the speed to F300 for the Z axis and F1200 for the X-Y axis movements. This is correct
G01 X104.7811 Y47.6195

The program is creating a cut out, and is cutting around 7mm deep per pass…. for a total depth of 21mm (cutting 3/4 inch wood)
At the end of a cut out, the spindle is moved back up, so it can move to the next cut out area. I used the default 5mm above the surface

This is where the PROBLEM is:

G01 Z-21.0000 F300 ;// this is where the Z axis is set to the last pass 21mm depth at F300 (300mm/min)
G01 X104.7800 F1200 // X-Y speed is set to F1200
G01 X104.7811 Y47.6195
G01 X199.9959 Y47.6200
G01 X200.0195 Y47.6187
G01 X200.0217 Y47.5149
G01 X200.0200 Y-6.8200
G01 X198.0864
G00 Z5.0000 // PROBLEM At least with the way Marlin works *********
The Z axis is being moved from the -21mm depth to +5mm total 26 mm… using the G00 command, with NO SPEED setting given

The last speed setting was the G01 command for the XY axis which was F1200 = 20mm/sec
Even though that speed was set using the G01 command, and the Z-Axis is being moved using the G00 command, Marlin uses the last speed set, period. Which was the 20mm/sec – and tries to move the Z-axis at that speed. For our Lead Screw Z-Axis that is way too fast… the Z-Axis at this point is told to move 26mm in just over a second…
Sometimes it makes it, but, other times it skips (or slips), and the head doesn’t raise up far enough.
It does this at the end of each cut, so what happens is the head cuts lower and lower at the end of each cut out

One workaround is to simply slow the machine way way down – but that isn’t a solution…

What I have to do is do Find and Replace all the Z axis movements that don’t have speed set and set the speed to F500

;No. 2: Cutout 2
G00 X451.7053 Y-6.8200 Z5.0000
G00 Z0.5000
G01 Z-7.0000 F300 // Here the speed for Z is set to the slower speed, but, AFTER the damage was done on trying to move the Z up too fast
G01 X358.7800 F1200

So, either Estlcam should have an option of setting speeds on the G00 rapid movement commands OR is there something in Marlin Configuration.h file i need to change?

The problem is, at the beginning of the Code no speed for G00 is set and the movements are extremely slow
Once a speed is set using the G01 command Marlin uses that speed for the G00 commands as well, it uses the last speed that was set, period, regardless of type of moving command or axis.
at the end of the cut when the Z axis is raised up because no speed setting is used Marlin uses the last XY faster speed to raise the Z axis – which causes Slip/Skip height problems

  • This reply was modified 5 months ago by Profile photo of UnLtdSoul UnLtdSoul. Reason: clarification