Home / Forum / Software / estlcam random dives / Reply To: estlcam random dives

Profile photo of UnLtdSoulUnLtdSoul
Post count: 9
#12899 |

I have notified both Ted/Vicious1 and Estlcam, I think I found the problem why this is happening. Getting a more solid Coupler is a good idea, and allows the Z axis to move faster – but, there is a problem with the EstlCam program and the way Marlin works.

What i found is when making cut outs, at the end of the cut out the head/spindle is raised up Estlcam uses the G00 Gcode command for this, which is the Rapid Movement command. Estlcam does not set the speed for G00 commands.
What Marlin does is it uses the Last Speed that was given regardless of command type (G01 or G00) and regardless of axis. Fnnn is the Gcode for setting speed of movement
for example, F1200 is 1200 mm/min or 20mm/sec
so during the cutout Estlcam sets the speed of the X-Y axis to F1200 using G01 commands
At the end of the cut Estlcam issues a G00 command to move the Z axis all the way back up to above the work surface to move to the next cut
BUT it does Not issue a Speed declaration…. So, Marlin uses the last speed setting, the F1200 and tries to move the Z-Axis back up at the full X-Y axis speeds
IF you have a good enough coupler, it may work. If you are using a printed one, it will probably slip and strip…
So, yes, one solution is to get a more solid coupler,

But, a better solution is for Estlcam to issue explicit speed declaration when moving the Z axis back up OR another solution would be if Marlin were to use a default speed when it gets the G00 command.