Cannot get the Z axis Squared.

New Home Forum Troubleshooting Cannot get the Z axis Squared.

This topic contains 16 replies, has 3 voices, and was last updated by Profile photo of vicious1 vicious1 3 weeks, 5 days ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #19685
    Profile photo of Chris Scott
    Chris Scott
    Participant

    Hi Folks, love my machine, have been using it happily for some small milling jobs, but recently tried to do a job with quite a close tolerence on some of the cuts and it came to light that my Z axis is quite badly out of square.

    I’ve checked and re checked the bed and rails and they are flat and parallel, everything is snug, all bearings rolling nicely and its smooth but I just can’t figure this Z problem, picture shows the extent of the issue.

    I hope someone has experienced this and knows of a fix, or maybe i need to reprint some parts, or perhaps I have overlooked something. Any help appreciated.

    Thanks all.

    View post on imgur.com

    #19687
    Profile photo of vicious1
    vicious1
    Keymaster

    Adjust the tension on the long bolt on the xyz part. looser on the bottom tighter on the top, or some combination like that.

    #19689
    Profile photo of Chris Scott
    Chris Scott
    Participant

    I’ve tried all manner of loosening and tightening on those 4 bolts with no success. Though thats not to say It wouldn’t work if i could get it right. I do need to give you some more info though which has just occured to me.

    When i first made the machine early this year it was the old design and the conduit I had which was supposed to be 25.0mm turned out to be undersized at around 24.7 – 24.8. The machine was sloppy, and unuseable. Time passed and the new center came to light so I got the 25mm beta models from you and printed them. Bought some new rails which are alittle over 25.0mm, around 25.2.

    My side rails were good, solid contact with all bearings and so I’ve never changed them they are still the original undersized steel conduit. The moving rails in the middle X , Y and Z are the new ones. Is it possible that this difference between the stationary side rails and the moving ‘carridge’ rails of around 0.4 – 0.5mm dia has put a twist in the center assembly?

    #19697
    Profile photo of vicious1
    vicious1
    Keymaster

    Not really.

    Do you have the same exact angle on both z rails or is your z assembly twisted. That angle should be pretty hard to get. You are using all the new middle parts correct, new tool holder and mounts all the new middle parts and z parts, it is a matched set the old and new do not mix or that angle can happen.

    #19707
    Profile photo of Chris Scott
    Chris Scott
    Participant

    Yes I replaced the entire center and all Z parts, spindle mount etc. That angle is identical on both Z rails, and its like the whole center has a twist in it. Here is a crude diagram to try to show where the error lies.

    The rods are square in one plane, out of square in the other, the arrow are trying to show which way it is twisted. My best guess is that one or more parts have printed wrong so I shall strip the whole thing and try to identify which is at fault, unless you have any other insight.

    Finally, just to add when I lay my Assembled Z on a sheet on flat glass it is perfectly flat, no twist in the assembled tubes at all.

    #19711
    Profile photo of vicious1
    vicious1
    Keymaster

    I would say take apart all the long bolts a have a look and follow the directions one more time and reassemble it. Now that you have an idea of what direction it was wrong, pay close attention when putting it back together. I am trying to build another one, I have all the parts ready and the table built so maybe today. But I have had to take the middle apart before myself. I think sometimes the fit is just too tight and when putting it together again loosens up the bolt holes a bit or something.

    #19714
    Profile photo of Chris Scott
    Chris Scott
    Participant

    I’ve got the center out and on the bench at the moment, and it is indeed twisted, it’s like a paralellogram i think. The parts themselves seem to be fine, they check out with a square. I’m leaning towards the bolt holes being misplaced perhaps its very hard to say. After striping it and reassembling it’s still out of square in exactly the same way it was before.

    I’m going to reprint the XYZ’s and perhaps that will sort it out.

    Or I will run and oversize drill through the bolt holes to loosen them up and give it more wiggle room so that i can tease it into the right alignment then tighten it all up.

    #19717
    Profile photo of vicious1
    vicious1
    Keymaster

    Is your printer square on all axis? Most printers z axis are not perpendicular.

    #19721
    Profile photo of Chris Scott
    Chris Scott
    Participant

    Thats a good question, and one that i can’t easily answer, when i check the XY peices with a square they are good, so I think its close enough to square, its certainly not noticably out of square.

    #19750
    Profile photo of Chris Scott
    Chris Scott
    Participant

    I think I’ve found the problem, after saying that i thought the XY’s were good they’re clearly not and it certainly looks like a problem with the Z on my printer. not sure i can do anything about that though.

    #19757
    Profile photo of vicious1
    vicious1
    Keymaster

    That’s not horrible, no way to move your z axis smooth rods around at all? You wouldn’t need much.

    These are things no one ever notices print fun stuff with printers, but once it comes down to dimensions and perpendicularity all hell breaks loose. Instead of company’s who sell fully assembled printers spouting of stupid things like layer resolution, or max print speed (both are BS and material dependent) they should give specs like axis perpendicularity tolerances and parallel. I used a big name printer and the to rails were so out of parallel you could travel the whole volume and it forced parts to slip fit that should slip!

    #19780
    Profile photo of Chris Scott
    Chris Scott
    Participant

    Aye, I hear you. Fortunately I didn’t spend massive money on my printer and its a self built machine based around 2020 aluminium section, with cartesian movement, kind of core XY type thing i think, thought might be mixing up whats what. Either way printer frame was slighting paralellogram so fixing that, then I’ll run a test print and hopefully be on the road to a win.

    #20257
    Profile photo of PureField
    PureField
    Participant

    Thanks for sharing ideas on how to square the Z-Axis. I am having the same issue however the parts are square (thanks Ryan) but still the Z-Axis is not in the X direction only. See pictures attached.

    I noticed it after I started printing real parts – not playing around.
    Printed a XY part (largest volume part of a build) for a second machine and it is way off, not the biggest problem for that part however. The wires got caught on the timing belt stopping movement in one direction…

    I have tried to adjust the 4 long bolts that mount the XY to the XYZ parts with decent success in the Y-direction but none in the X-direction.
    Any other ideas?

    Corners, height, dimensions and squareness are 100%. Rotated the tubes to have new surfaces.

    #20262
    Profile photo of vicious1
    vicious1
    Keymaster

    That is pretty close but if you want to get it closer the z axis is (should be) easy to fix. For the most part it is only the 4 bolts. After that it gets really complicated. The stainless one I just finished has so much less give, it took me two tries to get it square within a 1/16″ over 2′ at 1/16th” I can shimmy it before I start an important cut. After I put a few hours on it I will take the belts off and try and get it to at least half that.

    I digress.

    So, put some time on it to break things in or let the plastic stretch or whatever happens. Take the belts off, and readjust the center. I check all the middle bearings for tension by rotating them with my thumb. That really shows you what is tight or loose. On mine it really came down to just nudging some of the nuts.

    Remember that is amplified over the length of your z travel so if it was half as long it would be less than half as far off. Tangent or something math related like that. How far off is it at what length?

    #20263
    Profile photo of PureField
    PureField
    Participant

    After our last conversation about Z-Axis length, I reduced it by 4″. So the machine is now 8″ shorter in the flex direction (4″ Z-Axis + 4″ legs”).
    The Z-Axis is 12cm (about 5″) off the print surface (it is about 1/2″ off the table).
    The copper cooler I use as square (to fit under the XYZ assembly) is 9cm x 8.3cm. So the Z-Axis is about 1mm over 8.3cm out of square.

    #20422
    Profile photo of PureField
    PureField
    Participant

    Found the likely culprit. The XY assembly is not square.

    #20924
    Profile photo of vicious1
    vicious1
    Keymaster

    Who just emailed with a link to this thread? There is more than one issue here and more that on person.

    The z axis being out of square is simply an imbalance of tension between the top bolts and the bottom bolts. It is much easier to fix that than the x/y being out of square.

    1mm over 83mm is .69 degrees out of square. I hope you agree that is very close, and I assure you if you need it closer a little bit of very careful adjustment can get you closer. I would also look into how perfect the bed is, you are getting into territory that is hard to measure. It could be many things.

    I have this thread and your emails, and this thread has two people in it other than me, this is very confusing. It is difficult to compile the two into your issue. You asked for new parts in the email. I feel .6 degrees is so close that it can be adjusted a little closer but honestly I am not sure what the problem might be or how “perfect” any printer can get. The parts are plastic and they do flex a lot, and are designed to so they can be adjusted. If you look hard enough every printed part isn’t perfect.

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.