Different problems on the three axes (including the Z buzz / dive)

New Home Forum don’t use this one, I need to sort and delete -Troubleshooting Different problems on the three axes (including the Z buzz / dive)

This topic contains 40 replies, has 7 voices, and was last updated by Profile photo of Jamie Jamie 3 months, 3 weeks ago.

Viewing 30 posts - 1 through 30 (of 41 total)
  • Author
    Posts
  • #16505
    Profile photo of bradhaas
    bradhaas
    Participant

    Hi, it’s me again. Using parts entirely bought from you.

    X – my rollers move a little independently of each other. The one farthest from the middle assembly gets a little bit ahead of the other. This is especially evident if the machine is going back and forth rapidly – the X roller on one side moves a lot more while the one on the other side almost remains stationary.

    Y – it still feels rough when I move it by hand, and while the machine is running, that seems to translate into kind of bumpy/jerky movement. I’m holding out hope it’ll smooth out with use. Due to other problems I haven’t been able to tell yet if it really affects results.

    Z – I have that “diving” problem I’ve seen elsewhere in this forum. Seems that under certain circumstances, and I still can’t really tell which ones (except it only happens while running, not under manual control), my Z motor makes a loud buzz and doesn’t turn when it’s attempting to go up. It only happens a few times while running, too, not every time – but the result is that the tool just gradually goes lower and lower until it starts to get buried and I kill the process.

    Any ideas? I’m hoping the X issue is just that I didn’t tighten something correctly, and the Y issue might work itself out. I was able to find the most mentions of the Z thing here in the forum, and I tried a couple of the solutions but nothing seems to solve the problem entirely.

    #16506
    Profile photo of vicious1
    vicious1
    Keymaster

    Sounds like you are trying to move too fast, what speeds are you using? The diving problem (anti backlash being too tight, since has been removed) hasn’t really happened with the new parts. Same thing happened on here or by email yesterday and he was trying to move at speeds well above the firmware maximums of 197mm/s x and y, and 8.7mm/s Z.

    Try 30mm/s for the x and y, and 5mm/s for the Z. Does that fix it? If it does make sure you stay below the maximums.

    #16509
    Profile photo of bradhaas
    bradhaas
    Participant

    The X/Y speed for my tool in Estlcam is 15.0mm/s, and my F(z) is 3.0mm/s. Is there somewhere else that the speed might be set or affected?

    #16517
    Profile photo of Scott Adkins
    Scott Adkins
    Participant

    I had problems with the Z stepper skipping steps (at least I assume that’s what the buzz is), so I increased my Z driver voltage to 1v, and reduced the z maximum acceleration to 40, and that appears to have fixed it.

    The increase voltage does make the z stepper get rather warm, but I can hold onto it without much discomfort, so it seems fine.

    I think reducing the acceleration helped the most. Estlcam appears to have a bad habit of not specifying speeds on Z axis moves, so it likes to inherit the last speed used for x/y, which is way too fast.

    #16522
    Profile photo of bradhaas
    bradhaas
    Participant

    I saw the acceleration thing as a proposed solution elsewhere here, and I’d like to try it. But I got everything out-of-the-box from vicious1, so I didn’t set up the firmware myself. Is there a guide on how you might check / set the acceleration? I’ve searched but I can’t find one. Or could you point me in the right direction on how I’d do it?

    #16523
    Profile photo of Scott Adkins
    Scott Adkins
    Participant

    Unfortunately you have to modify the firmware. In theory you can alter it via the marlin interface, but for me at least it only allowed you to alter it in increments of 100, which is useless.

    This means you have to install arduino, download the firmware, alter the configuration.h, then upload it to your arduino/ramps board.

    These pages will help:

    Software

    Marlin Firmware

    The original acceleration was defined as:

    #define DEFAULT_MAX_ACCELERATION {400,400,55,800} // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

    And mine is currently: (changed 55 to 45)

    #define DEFAULT_MAX_ACCELERATION {400,400,45,800} // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

    But based on the marlin page above, it’s been changed to

    #define DEFAULT_MAX_ACCELERATION {400,400,40,800}

    Hope that helps

    #16525
    Profile photo of bradhaas
    bradhaas
    Participant

    Ohhhhh, OK. I’ve worked with Arduinos before, so that theoretically should be no problem. Thanks!

    #16529
    Profile photo of vicious1
    vicious1
    Keymaster

    On the firmware page I have the new/old marlin update it actually has the lower accel already done so Just flash that one if you are uncomfortable.

    The new marlin has been released so I need to start again, but I need to finish these instruction updates first.

    #16604
    Profile photo of bradhaas
    bradhaas
    Participant

    I flashed the firmware with the Z acceleration changed to 40, but I still have the occasional buzzing problem. My X rollers are still out of sync too. I made a video:

    https://www.youtube.com/watch?v=pHfM3th7Py4 on most of it you can see the X roller on the right side is moving more freely than on the left, so the axis is just kind of swinging back and forth. Toward the end there are two instances of the Z control doing the buzz/grind thing.

    I did notice that after I had connected and moved the rollers a bit using RepetierHost (so the motors are energized or whatever), I’m able to move the left-hand X roller pretty easily, while all others resist being moved. Does that shed any light on the problem?

    #16609
    Profile photo of vicious1
    vicious1
    Keymaster

    hmm, okay seems like a stepper is not connected, or is wired wrong. Disconnected it and switch it with another stepper. When energized it should be locked.

    Still seems like your z axis it trying to move way too fast. Lets see your gcode.

    I will try to get another kind test code together (machine is apart to take pictures), I have three others up there somewhere. I am updating the instructions and looks like it would come in handy.

    #16610
    Profile photo of Scott Adkins
    Scott Adkins
    Participant

    Keeping in mind I’m a newbie with MPCNC’s and don’t have much experience:

    Wild guesses/things to check for the x-axis:

    Are the pulley’s secured properly on the motors?
    Belt tension on both sides roughly equal?
    If the belts are removed, does the rail slide smoothly? If not, perhaps some bearings are too tight on one side?

    For the z… Make sure the coupler is tight.. Check the vref for the z driver? As I said, I increased mine to 1v. Mine sounded just like yours, I assume that’s “skipped steps”, but I don’t know for sure.

    #16612
    Profile photo of vicious1
    vicious1
    Keymaster

    I don’t have a machine to try it on today but this should be good to go.

    Attachments:
    1. circle-test.zip
    #16614
    Profile photo of bradhaas
    bradhaas
    Participant

    @vicious1 thanks, I’ll try that. Is it possible there’s a stepper problem when one motor works and the other doesn’t, and they’re both connected to the same stepper? I will try switching things up though, to see if I can get that loose motor to lock when connected to one of the other ones.

    Looking at your gcode, it dawns on me that I may have used the wrong file, that I created before enabling the “add F to every instruction” thing in Estlcam. I’ll double check that.

    @Scott I’m pretty sure everything you asked about is good, but I’ll double-check. I did verify the vref for the Z driver but I haven’t tried increasing it yet.

    #16615
    Profile photo of bradhaas
    bradhaas
    Participant

    ARGH! I re-saved the gcode from Estlcam with “repeat F commands” enabled, and a few of the Z commands are set correctly to 180, but the rest are set to 900! Anyone know offhand where I can fix that in Estlcam?

    I changed around my motors/steppers and it remains the same – one motor is locked and the other still has some play. I discovered that the same is true on the Y rollers but much less so. In both cases, it’s the one that’s more distant from the driver, if that makes any difference. I did check that the wire connection between the X motors is secure.

    #16616
    Profile photo of vicious1
    vicious1
    Keymaster

    Slow down. You are changing too many things at once. I am lost.

    You physically moved the stepper and that same roller is not moving? That would suggest your belt is too tight, your roller is too tight, or you have a bad wire.

    Lets do this one issue at a time, because you are having so many issues I am guessing a build problem like bolts are too tight.

    To do these tests stop using gcode, for now, one less issue to deal with. Use repetier through usb to your machine. Issue manual commands. Move the x and y axis back and forth 100mm a few times? Any issues?

    #16617
    Profile photo of vicious1
    vicious1
    Keymaster

    Use these speeds in repetier.

    Attachments:
    #16621
    Profile photo of bradhaas
    bradhaas
    Participant

    OK – under manual control everything goes just fine. In general the machine is able to move around on X and Y very well.

    What I meant in my previous post is that, when the motors are energized, I can wiggle one entire X roller assembly by hand (several mm in either direction) but I’m not able to move the other one at all by hand. For further testing, I unplugged the X and Y plugs from the RAMPS board and swapped them, so my X rollers were plugged into the Y driver and vice versa. After that I energized the motors again and I was still able to wiggle the same one. I don’t actually know if this indicates a problem or not. I put everything back the way I started though.

    To sum it up, I have two main problems right now. One is that one of my X rollers gets a little ahead of the other one, as you can see in my video.

    The other is the Z motor grind/buzz thing, but I’m pretty confident that’s a problem with my gcode generation because when I read the gcode, most of the Z axis commands have F900 with them (which is my X/Y speed) instead of F180 like they should. A few do have F180, but I think it’s just the first one in each cut.

    #16632
    Profile photo of vicious1
    vicious1
    Keymaster

    Sticking with the x and y problem.

    That does not make sense, manual control works fine? When do you get the wobbly axis then?

    By you swapping the x and y at the board you have narrowed the problem down to either a bad stepper, wiring, belt, or hardware on the affected axis (basically you verified the arduino and drivers are good). Physically swap out the one affected stepper to find out if it is the stepper or the other issues. You could also take off the belts and check each stepper for motion/torque. Generally the stepper will either turn at full power (correct), make a bunch of noise (wires got swapped), or not move (no connection), or possibly one coil is disconnected and you are getting very little power.

    A belt that is too tight will stall the stepper and it will lagg behind, bolts too tight will have too much drag and lagg behind, no power down the wires to that stepper will not energize the coils and it will just go along for the ride.

    #16646
    Profile photo of Barry
    Barry
    Participant

    Just for giggles, unplug the X stepper that doesn’t wiggle, then try moving X with repetier. Sounds like you have either a bad wire to that stepper, or the stepper is bad.

    #17225
    Profile photo of bradhaas
    bradhaas
    Participant

    Well, I disconnected the good X stepper and found the bad one didn’t move at all. I pulled the wires out again and disconnected/reconnected them again, and it started working. I did that once before, but apparently the connection came loose right away inside the conduit. I’ll definitely wrap that connection securely with tape now, and maybe do that loop trick with it too to make it more self-disconnection-resistant.

    I’m so sorry, guys, I feel dumb for not figuring that out sooner. I guess I underestimated the extent to which just one working stepper can move the entire assembly. I wish they included LEDs or something to make them more idiot-proof for idiots like me. 🙂

    I did notice that once I reconnected the good X stepper, it didn’t work at all until I fully unplugged the RAMPS board then plugged it back in. Maybe that was part of my problem all along too.

    In any case, it moves very solidly now, and I’m pretty sure the Z problem was because of F900 being generated by Estlcam. Hopefully I’ll have some nice things to show off in the “build” forum soon.

    #17244
    Profile photo of bradhaas
    bradhaas
    Participant

    Sigh. X/Y movements work great now that all motors are actually running. But I still have a Z problem, it turns out. I edited my gcode so that the Z movements are always at speed 180 (3 mm/s), so everything was nice and slow. It worked well at first, but eventually it wasn’t able to move up from the piece to the clearance plane, so it was moving around very close to the piece, then it missed another upward motion, and started going deeper into the piece as a result. I stopped it and tried to use manual control to bring it up, and it wouldn’t move – it just did more of the buzzing. I took a video of trying it a few times:

    Toward the end of the video I move it downward a small amount, then try to move it up again. It goes back to the stuck position and resumes the buzzing.

    After I stopped taking video, I lifted the spindle manually while I did the Z-up command in RepetierHost. Finally it did move, and then was able to move up and down freely.

    Has anyone seen this? Anything I’m missing that would cause it?

    #17246
    Profile photo of Matt saeger
    Matt saeger
    Participant

    Have you tried to move the Z motor with it removed from the machine? I would guess there is binding somewhere. I had Z issues at first until I put a bunch of grease on the threaded rod.

    #17247
    Profile photo of bradhaas
    bradhaas
    Participant

    Thanks Matt, I’ll try that.

    #17250
    Profile photo of bradhaas
    bradhaas
    Participant

    I’ll still try adding grease to the threaded rod, but as a first step I tried loosening my anti-backlash nut. At least, I think that’s what I loosened – the one on the bottom of the 5″ bolt in the middle assembly? That seemed to work, and I did a successful carve of a design from Vectorink.com. 😀

    P.S. @vicious1 I just noticed you revamped the assembly instructions. They look awesome!

    #17271
    Profile photo of vicious1
    vicious1
    Keymaster

    Thanks I’m finally have most of the info now, I just try in fill in any missing details when I get questions about a step.

    As for your z axis, 3 things to try. It really sounds like you have some binding, double check the rod, maybe clean and re lube it. You can flash my new firmware it has a slower z acceleration (same max speed for now), and you can also turn up the z driver to .7V.

    #18258
    Profile photo of Jamie
    Jamie
    Participant

    Hey, just wanted to say thanks. I had the exact same problem with my Z. Changed the voltage to 0.7 and it works fine now !
    Just a quick question which I couldn’t find an answer to. Is there a way to make the auto home command go to the home that is set when pressing set home offsets ? Is there a way to hard code 0,0,0 to a particular position without end stops (Im guessing no here)?

    #18280
    Profile photo of vicious1
    vicious1
    Keymaster

    Not easily from the screen. You can send a command from repetier or another software to go to position, 0,0,0..

    I think it’s
    G90 X0 Y0 Z0

    #18435
    Profile photo of bradhaas
    bradhaas
    Participant

    Just wanted to say thanks again to everyone. I think my Z problem was indeed the anti-backlash nut being too tight, but I lubed the threaded rod anyway and another test carve went perfectly.

    #18472
    Profile photo of John
    John
    Participant

    I’m having some similar Z problems and I’m trying to follow your suggestions:

    “You can flash my new firmware it has a slower z acceleration (same max speed for now)”

    I’ve flashed my firmware to drop the Z acceleration value from 55 to 35. I have also reduced the Z speed for the tools in Estlcam to 1mm/s. There are a few places in Estlcam’s generated g-code that ignore this value, so I’ve manually edited the g-code to reduce F values even further where necessary to not exceed 1mm/s Z axis travel. Given the max value you suggest at 6.7mm/s I am assuming this is slow enough. These have improved my results, but not eliminated the issue.

    “double check the rod, maybe clean and re lube it.”

    I have completed this step. As far as I can tell the rod is straight, the coupling appears to be fine, and without power to the motor it turns very freely. I’ve had to leave the nut assembly fairly loose which I’m hoping won’t cause its own issues. I have not tested this to see if it resolves the issue because I would like to also attempt the third suggestion:

    “You can also turn up the z driver to .7V.”

    Here I have run into problems. Following the Pololu video linked in the RAMPS instruction page I have attempted to determine the currently selected voltage. However, my multimeter is reading 4.3v between the pot and the vref pin, which is very far away from 0.7v. Advice on this point would be much appreciated. Thanks! 🙂

    #18599
    Profile photo of Jamie
    Jamie
    Participant

    So this happened after upping the voltage to 0.7 on the Z axis !
    CNC was running fine then there was a big pop and the cable going in to the power supply was on fire !

    Coincidence that Id upped the voltage ? It seems like such a small increase in power, surely it wouldnt cause this ?

    Any thoughts welcome. Ive since replaced the cable and run the CNC briefly without issue.

Viewing 30 posts - 1 through 30 (of 41 total)

You must be logged in to reply to this topic.