estlcam random dives

New Home Forum Software Development estlcam random dives

This topic contains 18 replies, has 8 voices, and was last updated by Profile photo of Ryan Ryan 1 year, 1 month ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #8176
    Profile photo of Maker Baker
    Maker Baker
    Participant

    I’m running some test cuts with and 4 out of 6 test I’ve done randomly dive my z into the work causing it to jam up x and y… any ideas?

    #8181
    Profile photo of Leo69
    Leo69
    Participant

    Did you try to move your spindle up/away from the work surface by hand? If it’s moving up by hand then your z nut lock is loose.

    #8186
    Profile photo of Ryan
    Ryan
    Keymaster

    Yup could be the z nut slipping or check your gcode to make sure it isn’t in the program. load it in repetier and check the box that says show travel moves.

    #8216
    Profile photo of Maker Baker
    Maker Baker
    Participant

    z nut lock… are you talking about the coupler?

    #8217
    Profile photo of Maker Baker
    Maker Baker
    Participant

    here is some pics, of the 4 tests, the spiral and star dug with dremal, but my last name did not. so I went to your wright up for estlcam and made the tool bit for the pen (used sharpie) and tried the map, you can see where it progressively gets deeper until it actually jammed and ruined my new sharpie!!

    #8223
    Profile photo of Maker Baker
    Maker Baker
    Participant

    ok, good idea, it must be mechanical because repetier isn’t showing any deeper, atleast I don’t think so. here is a screen shot

    Attachments:
    #8225
    Profile photo of Ryan
    Ryan
    Keymaster

    Zip and Upload that gcode. It looks like it has some step downs to me. You need to view it from the side.

    #8226
    Profile photo of Ryan
    Ryan
    Keymaster

    Actually try out that file in the estlcam walk through. That only has one z move.

    #8227
    Profile photo of Maker Baker
    Maker Baker
    Participant

    I will gladly upload, if you could just tell me how to zip n upload to where…. I just checked the map I did with the walk threw setup doesn’t appear to have any more then one z drop.

    Attachments:
    #8237
    Profile photo of karltinsly
    karltinsly
    Participant

    I had problems with the z going deeper and deeper during a cut. In my case the rigid coupler was loose enough to let the all thread slip occasionally.

    #8265
    Profile photo of Maker Baker
    Maker Baker
    Participant

    what size real coupler should I order?

    #8267
    Profile photo of Ryan
    Ryan
    Keymaster

    The right sized couplers are really expensive. 5/16 to 5mm. 8mm to 5mm does not work well enough in my opinion.

    Did you check your z nut lock, or try my file from the estlcam page?

    #8296
    Profile photo of Maker Baker
    Maker Baker
    Participant

    Ok I’ll order one tonight or make one at work. Yes I tried the file and still dived. Turns out the printer couples is stripped I am using the older z stepper mount so it doesn’t have much bite on the rod and having the Z axis going to fast and the weight didn’t lift it so every negative z movement just went down n down n down

    #8736
    Profile photo of James
    James
    Participant

    I bought a 5 to 8mm and ground a flat face at the top of my Z rod to settle one of the set screws in to. Works perfectly. Also found, my Z stepper driver was skipping at the recommended current so I cranked it up to .750 volts and it works perfect now.

    #12899
    Profile photo of UnLtdSoul
    UnLtdSoul
    Participant

    I have notified both Ted/Vicious1 and Estlcam, I think I found the problem why this is happening. Getting a more solid Coupler is a good idea, and allows the Z axis to move faster – but, there is a problem with the EstlCam program and the way Marlin works.

    What i found is when making cut outs, at the end of the cut out the head/spindle is raised up Estlcam uses the G00 Gcode command for this, which is the Rapid Movement command. Estlcam does not set the speed for G00 commands.
    What Marlin does is it uses the Last Speed that was given regardless of command type (G01 or G00) and regardless of axis. Fnnn is the Gcode for setting speed of movement
    for example, F1200 is 1200 mm/min or 20mm/sec
    so during the cutout Estlcam sets the speed of the X-Y axis to F1200 using G01 commands
    At the end of the cut Estlcam issues a G00 command to move the Z axis all the way back up to above the work surface to move to the next cut
    BUT it does Not issue a Speed declaration…. So, Marlin uses the last speed setting, the F1200 and tries to move the Z-Axis back up at the full X-Y axis speeds
    IF you have a good enough coupler, it may work. If you are using a printed one, it will probably slip and strip…
    So, yes, one solution is to get a more solid coupler,

    But, a better solution is for Estlcam to issue explicit speed declaration when moving the Z axis back up OR another solution would be if Marlin were to use a default speed when it gets the G00 command.

    #12910
    Profile photo of Ryan
    Ryan
    Keymaster

    I emailed about this a while ago. Pretty sure he said there was a place to change the z-axis speed independent of the other axis. I just cut a bunch of stuff for a few more printers and haven’t ran into this problem. Maybe I just have all my moves set at a low speed and it doesn’t happen.

    #12968
    Profile photo of Jason
    Jason
    Participant

    Just took a loot at the settings….looks like:

    Setup -> CNC program generation -> Values -> F | Rapid Feed

    Would be the setting to change. The default is blank.

    ToolTip for it is:

    If your CNC controller requires feedrate information for G00 commands enter the desired feedrate here and activate the checkbox to repeat “F” with every line…

    Which sounds exactly like what’s needed 😀

    #13053
    Profile photo of Curt
    Curt
    Participant

    So what would be a safe setting for the rapid feed rate field?

    #13056
    Profile photo of Ryan
    Ryan
    Keymaster

    With the recommended electronics max X and Y is 197mm/s and Z is 8.7mm/s. I think I am going to switch to 8th or 16th stepping through, as soon as I find a way to test it.

    I would stay under the max though.

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.