Home / Forum / Software / I need some help with ESTLCAM and Repetier to try to figure out my Z-Axis Woes

Viewing 3 posts - 1 through 3 (of 3 total)
  • Profile photo of Jason G PottsJason G Potts
    Post count: 0
    #6199 |

    Hoping someone could help me out here.

    I have drawn a basic shape in ESTLCAM and configured it so that the Z-Axis origin is set to “Material Upper Side”
    I have entered the routing toolpaths and created a NC file that I then copy and paste into the Repetier G-Code Editor

    Repetier then shows all of the travel moves fine, but under the grid (I assume because it will be going negative)

    I set the axis home (0 positions in the manual control) so that the numbers change from red to black zeros for X/Y/Z Axis’

    Here is the problem:
    When I run the program, the X/Y Move as they should, but the Z steps upward….
    I looked at Repetier and manually jogged the Z axis +numbers run the tool up and -numbers run the tool down.
    I assume that this is what I want… (For some reason it will also not let me go past zero into negative numbers)
    I verified that the Z axis Max was set to 20 and the Min was set to -20 in the firmware.

    What am I missing?


    Profile photo of Leo69Leo69
    Post count: 342
    #6205 |

    I don’t know anything at all about Repetier so I’m not sure what happens when numbers change from black to red? Try manually jogging the Z axis until the tool tip is touching the top of the material and then send a G92 Z0 command through you gcode sender. This should set you Z axis to 0, then try running your program.

    Profile photo of vicious1vicious1
    Post count: 2657
    #6206 |

    You aren’t using my firmware? I enabled negative movements and it is also shown in the walk through.

    Marlin Firmware – New Beta Available

    – #define min_software_endstops false (needed to machine in the negative direction)

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.