letting out the magic smoke

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC letting out the magic smoke

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of nerdyrcdriver nerdyrcdriver 1 year ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #14448
    Profile photo of John
    John
    Participant

    well that just stinks (literally). I set up the unit in the garage where it should be nice and happy and somehow or another the raspberry pi over or undervolted the mega as it was powering it and something is burned up. the PI seems to be acting normally still, so I’m betting it’s on the Mega. I’m crossing my fingers it just the regulator on the USB input.

    #14452
    Profile photo of John
    John
    Participant

    Wow. Smoked both regulators at once. That’s a first for me…

    #14459
    Profile photo of Ryan
    Ryan
    Keymaster

    Well you put my soldering skills to shame…

    #14460
    Profile photo of nerdyrcdriver
    nerdyrcdriver
    Participant

    One of my electrical engineering teachers goes by the idea “The magic smoke is what makes electronics work. You can usually let out a little bit of it, but if you let too much out your circuit won’t work anymore”. I was told that right after someone gave me the wrong schematic and a 555 timer IC literally split itself in half when I turned on the power.

    Is that a real Arduino Mega or a knock off? The knock offs use terribly cheap regulators that can’t handle much deviation.

    At least is is probably an easy fix if you can get the regulators cheap enough.

    #14462
    Profile photo of John
    John
    Participant

    New regulators on the way… woohoo. I’m still a bit surprised that the ramps board uses the arduino regulator for power. That really surprises me. I will put a heat sink on it after the new one is put in. The ramps wiki though clearly indicates that’s what it does though… the good news is I can power the mega from the ICSP header and it powers fine and the usb shows up nicely, so it’s all working at that point. tomorrow i’ll hack up a 5v supply to directly power it for a bit and make sure I didn’t fry the ramps board, though I really doubt that would be likely…

    #14464
    Profile photo of nerdyrcdriver
    nerdyrcdriver
    Participant

    Yeah, 5v isn’t to hard to come by. I think the ramps board itself is a pretty robust board, it’s usually the stepper drivers that people tend to have issues with. Even if it is the ramps board, a replacement without any drivers or other accessories isn’t very expensive.

    #14550
    Profile photo of John
    John
    Participant

    And we are back in the saddle again… 🙂

    Attachments:
    #14655
    Profile photo of nerdyrcdriver
    nerdyrcdriver
    Participant

    And everyone says that i’m good at soldering. Did you use glue or something sticky to hold the parts down while you soldered them?

    Also, does it work again?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.