MK8 Extruder Issues

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of Bryan Bryan 2 weeks, 5 days ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #23936
    Profile photo of Bryan
    Bryan
    Participant

    I’m banging my head against the wall trying to figure out why I can’t get the MK8 extruders working. I have set the vref on the DRV8825 anywhere from 0.5V to 0.75V. I am able to have the extruder pull filament through the drive gear and down to the throat. It seems to be hit or miss if the filament actually makes it into the throat, or just gets caught on the lip and the motor clicks and does not push it any further.

    On the occasion that the filament makes it into the throat and down towards the nozzle, it seems to jam at this point. No plastic will extrude anymore. I have taken the assembly apart several times and cleaned the nozzle and throat. Is it possible that I do not have enough cooling via the heatsink and fan to prevent heat from creeping and expanding the filament higher up in the throat?

    The only other thing I could think of is a higher vref on the DRV8825 but I’m already at 0.75V on a 1.5A rated stepper and I do not want to push it too much higher. The stepper is relatively cool, though.

    #23937
    Profile photo of Dave Gun
    Dave Gun
    Participant

    A few things you can try:

    Use a wire cutter and cut your filament at a 45 degree angle. Straighten the end of the filament so it isn’t curved. Bring the hot end up to temperature and hold the lever down on the extruder. Feed the filament in until you feel it enter the throat. Put a little pressure on the filament and you should see some extrude out the end of the hot end. This way you know the filament is in the throat.

    If you have a jam, heat the hot end up above your printing temperature maybe 10-20 degrees and let the filament ooze out. Hold the lever down and push new filament through and push out some filament through the extruder. When switching from ABS to something like PLA, bring the temp up to about 250 to get the ABS out of the hot end. I like to then run about 100mm of filament through to make sure any old filament is out.

    Another trick I use to clear out everything from the hot end is to start cold and bring the temperature up to just where the filament gets soft. For PLA, about 90 degrees, then press the extruder level and pull out the filament. It may take a firm pull. This will remove the filament all the way down the throat and sometimes even out of the nozzle. This will pull out and clean every thing out from the inside. I attached a picture of the last ABS I pulled, I think it was about 120 degrees when I pulled it. In the picture you can see the extruder gear marks at the top all the way down to the nozzle at the end.

    I hope this helps, good luck!

    Dave

    #23956
    Profile photo of Bryan
    Bryan
    Participant

    Thanks for the tips, Dave. I’ll be sure to give them a try.

    I shortly noticed I made a rookie mistake – I didn’t have any jumpers underneath the extruder driver. I’m running the firmware in 1/32 microstepping mode, but the driver thinks I want full steps. I’m going to clear the PTFE liner and try again.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.