Home / Forum / Software / Motors not responding to all manual controls

Viewing 6 posts - 1 through 6 (of 6 total)
  • Profile photo of DouglasDouglas
    Post count: 2
    #6104 |

    I have completed my build, and am now at the point of testing out the electronics / steppers. I am just attempting to get the machine moving and will eventually use it as a CNC router, and do not currently have plans to use it as a 3D printer.

    All the stepper motors are wired up correctly as far as I can tell. When i open up Repetier-host, and attempt to use the manual controls from the “Print Panel”, I am able to successfully send the X, Y and Z to “home” by pressing the home button for each axis. However, when i attempt the to do incremental steps (0.1, 1, 10, 100) nothing happens and I get this error in the console log:

    < 12:32:19 PM: Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

    Here is my log when Repetier-host initially connects. NOTE at the end there is a temperature error here as well:
    12:43:13 PM: Attempting to connect to printer
    12:43:13 PM: Connection opened
    < 12:43:22 PM: start
    > 12:43:22 PM: N1 M110 *2
    < 12:43:22 PM: echo:Marlin1.0.2
    > 12:43:22 PM: N2 M115 *4
    < 12:43:22 PM: echo: Last Updated: Jan 20 2016 9_06_1511:47:29 | Author: PID, ALLTED
    < 12:43:22 PM: Compiled: Jan 20 2016
    > 12:43:22 PM: N4 M111 S6 *67
    < 12:43:22 PM: echo: Free Memory: 5441 PlannerBufferBytes: 1232
    > 12:43:22 PM: N5 M111 S14 *113
    < 12:43:22 PM: echo:Hardcoded Default Settings Loaded
    < 12:43:22 PM: echo:Steps per unit:
    < 12:43:22 PM: echo: M92 X200.00 Y200.00 Z4535.44 E200.00
    < 12:43:22 PM: echo:Maximum feedrates (mm/s):
    < 12:43:22 PM: echo: M203 X9000.00 Y9000.00 Z3.00 E25.00
    < 12:43:22 PM: echo:Maximum Acceleration (mm/s2):
    < 12:43:22 PM: echo: M201 X700 Y700 Z100 E800
    < 12:43:22 PM: echo:Acceleration: S=acceleration, T=retract acceleration
    < 12:43:22 PM: echo: M204 S700.00 T800.00
    < 12:43:22 PM: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
    < 12:43:22 PM: echo: M205 S0.00 T0.00 B20000 X4.00 Z0.40 E5.00
    < 12:43:22 PM: echo:Home offset (mm):
    < 12:43:22 PM: echo: M206 X0.00 Y0.00 Z0.00
    < 12:43:22 PM: echo:PID settings:
    < 12:43:22 PM: echo: M301 P12.03 I0.60 D60.60
    < 12:43:22 PM: echo:Filament settings: Disabled
    < 12:43:22 PM: echo:Z-Probe Offset (mm):
    < 12:43:22 PM: echo: M851 Z0.00
    < 12:43:22 PM: Error:0
    < 12:43:22 PM: : Extruder switched off. MAXTEMP triggered !
    < 12:43:22 PM: Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
    < 12:43:23 PM: FIRMWARE_NAME:Marlin V1; Sprinter/grbl mashup for gen6 FIRMWARE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:MPCNC EXTRUDER_COUNT:1 UUID:00000000-0000-0000-0000-000000000000

    I have tried the same thing in Pronterface and Simplify3D, and all give me the same errors. I have also tried on windows and mac with same result, so i assume it is a configuration i am unaware of, but i am not sure if it is a Marlin firmware config, or a setting in Repetier-host or something else. I am also not sure if I was supposed to hook up the resistor on the RAMPS board that came in the kit, even though i am not intending to do 3D printing?

    I purchased the hardware/electronics kit from this site, and printed my own parts. The kit was purchased about 2 weeks ago.

    Any assistance is greatly appreciated! This is my first CNC build, and am new to the software and firmware.

    Profile photo of Bert DanielsBert Daniels
    Post count: 1
    #6107 |


    I’m still in the process of building the mpcnc myself but I guess it is the missing resistor on the T0.

    See link to other post



    Profile photo of vicious1vicious1
    Post count: 2642
    #6109 |

    Yup you need the resistor on pins t0, repetier should then show a temp of about 25C when you connect.

    Profile photo of DouglasDouglas
    Post count: 2
    #6110 |

    Yep, that was the problem! I guess i misunderstood, and thought i only needed to hook that up if I was using it for 3D printing. Manual controls work great now.

    Also, just as a matter of documentation, i saw some posts where people had problems communicating with the board on a Mac. I edited the configuration.h in the firmware, and changed
    #define BAUDRATE 250000

    to be

    #define BAUDRATE 115200

    and now i can connect to the board no problem.

    Thanks again for the quick response Bert.

    Profile photo of vicious1vicious1
    Post count: 2642
    #6112 |

    Good tip thanks, I don’t have a mac to test with so that helps.

    Profile photo of DouglasDouglas
    Post count: 2
    #6113 |

    Yeah, one other thing I had to do to get Arduino IDE and Repetier to connect on my Mac running El Capitan OS was install the drivers for the Chinese Mega. I got the driver and instructions from this site: http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html. Installing that driver, along with changing the baudrate in the firmware seemed to do the trick. I’ll update as i progress if there is anything else i find.

    Great design BTW…cant wait to start my first cuts…

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.