Recommended case for ramps and full graphic card?

New Home Forum Assembly Recommended case for ramps and full graphic card?

This topic contains 18 replies, has 5 voices, and was last updated by Profile photo of PJM PJM 2 months, 1 week ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #18285
    Profile photo of PJM
    PJM
    Participant

    Do you guys have a case that I can print to house these cards for my mpcnc? What do you recommend? Just want one to sit on a desktop for the time being.

    #18286
    Profile photo of vicious1
    vicious1
    Keymaster
    #18292
    Profile photo of KronBjorn
    KronBjorn
    Participant

    Not an option yet, but I am working on a six-inch rack mountable case,…

    There will also be one for the small LCD, a Raspberry, a PSU, maybe a LED driver, etc.

    Attachments:
    #18294
    Profile photo of gotsanity
    gotsanity
    Participant

    This is the one I use: http://www.thingiverse.com/thing:1029926

    It works great, only caveat was I had to ditch the knob and use the one that came with the board (not really a big issue) and the hinge came out a little rough due to supports.

    #18484
    Profile photo of PJM
    PJM
    Participant

    Is there something special about the ramps board from you guys? It seems that most cases I’ve tried, the power connector is in the wrong location. It’s a little too far to the outside edge of the board (to the right when looking at the connector).

    Just wondering..

    #18489
    Profile photo of vicious1
    vicious1
    Keymaster

    Make sure it is designed for the current ramps 1.4, there are still some earlier designs out there. We don’t use the mega power port just the ramps plug.

    #18491
    Profile photo of PJM
    PJM
    Participant

    Figured it out. The connector is soldered on slightly skewed to the right.

    #18646
    Profile photo of PJM
    PJM
    Participant

    So I’ve got lots of used plastic now. Fixed a few issues with my 3d prints along the way. But even though, many of the cases, even though they say they are for the RAMPS 1.4, don’t line up with my board at all. The connectors seem to be on the board in the appropriate positions as marked on the board, but don’t line up with most cases. Compared to my other RAMPS 1.4 board, the connectors are not in the same positions at all. My other board lines up perfectly.

    What gives…? Any ideas Vicious1?

    #18648
    Profile photo of vicious1
    vicious1
    Keymaster

    Are you sure your other board is a ramps 1.4?

    Can you upload some pics please.

    #18654
    Profile photo of PJM
    PJM
    Participant

    Files attached. It’s the mega 2560 knock off that is not aligned properly.
    The ramps board screw holes don’t line up with the original mega2560 either.
    🙁

    #18656
    Profile photo of vicious1
    vicious1
    Keymaster

    I have never noticed. All the cases I have made I used the arduino specs and they seemed to fit.

    Feel free to send it back for a refund.

    #18657
    Profile photo of PJM
    PJM
    Participant

    File 2

    #18658
    Profile photo of PJM
    PJM
    Participant

    K, guess I’d have to make the files smaller. Stand by.

    #18659
    Profile photo of vicious1
    vicious1
    Keymaster

    Arduino Hole Dimensions Drawing

    I just checked the adafruit specs and the holes match, (one doesn’t have dimensions).

    I don’t have eagle so I can’t use the arduino layout.

    #18660
    Profile photo of PJM
    PJM
    Participant

    Here are comparisons between my boards and the ones I got from you guys.
    – connectors on 2560 don’t line up with original.
    – reset switch on the Arduino doesn’t line up with original.
    – screw holes on the Arduino don’t line up with Either 2560 or my Original Arduino.

    So, put another way.
    – 2560 connectors misaligned.
    – Arduino reset misaligned.
    – Arduino holes misaligned.

    Please confirm this but that’s what I can tell with what I have here. I have a pile of plastic in the recycle parts bin to prove it :(. Those pieces btw fit my original h/w perfectly.

    #18666
    Profile photo of vicious1
    vicious1
    Keymaster

    I’m not sure what you want me to do, You are welcome to return it, no problem. The specs match from what I can see, all soldered components have a tolerance and will always vary much more so in through hole mounts. The holes match on the board and the ramps.

    If it’s just a case that doesn’t fit, what one is it?

    Did you get your mega from arduino? The bottom will be white if it is.

    Again, what would you like me to do?

    #18667
    Profile photo of PJM
    PJM
    Participant

    All this was ordered from you guys. The mega is not from Arduino. It has the chinese chip on it. The RAMPS is also not from Arduino but rather http://www.bigtree-tech.com.

    Electronically they work, but it’s annoying spending days trying to figure out why stuff don’t fit, second guessing your printer and so forth. If it doesn’t fit for me, it ain’t gonna fit any better for others. Just want people to know.

    Tried the following from thingiverse:
    http://www.thingiverse.com/thing:1029926
    http://www.thingiverse.com/thing:1640870
    and several others.

    I don’t want you to do anything other than just let others know so they don’t end up wasting their time either. That’s all.

    Other than that, loving my mpcnc. Not cutting anything yet but soon…

    #18670
    Profile photo of Alvin
    Alvin
    Participant

    Most RAMPs and Arduino clones don’t exactly match the originals. I recently ordered a RAMPS clone from Amazon and the pins below the board are out of whack but they work 🙂

    I’m currently using the Minions enclosure and I actually need to file/remove stuff to fit the boards which I expected before printing it.

    I’m adding new hardware like the Pi and laser driver so I’m switching to the modular enclosure (http://www.thingiverse.com/thing:1045751) which doesn’t really need an exact placement of the ports

    Attachments:
    #18672
    Profile photo of PJM
    PJM
    Participant

    Sorry Vicious1. My 2560 is from Arduino yes. The bottom is white. Got it with my Ecksbot 2014 that I purchased from Ecketech in Toronto.

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.