X & Y Move togther

This topic contains 9 replies, has 3 voices, and was last updated by Profile photo of Ryan Ryan 1 year ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #13777
    Profile photo of robert bobbitt
    robert bobbitt
    Participant

    in repetier when I do manual moves both X & Y move together
    they cant be wired together YL & YR are wired together in same wire race XL & XR are in another race
    I think I included pictures of my wiring.

    #13785
    Profile photo of Mike Cunningham
    Mike Cunningham
    Participant

    What firmware are you using? Is it the on pre-loaded by vicious1?

    If not, confirm your pins.h (pins_RAMPS14_EFB.h or w/e your using), make sure they are not on the same pin..

    The alternative is that you may have a defective RAMPS/Arduino (or both), or theres a speck of solder/metal on one of them.

    You could build a simple sketch to confirm:

    #define Y_STEP_PIN         60
    #define X_STEP_PIN         54
    
    void setup() {
      pinMode(54, Y_STEP_PIN);
      pinMode(60, X_STEP_PIN);
    }
    
    void loop() {
      digitalWrite(Y_STEP_PIN,1);
      digitalWrite(X_STEP_PIN,0);
      delay(500);
      digitalWrite(Y_STEP_PIN,0);
      digitalWrite(X_STEP_PIN,1);
      delay(500);
    }

    remove the stepper drivers, and connect a LED from the STEP pin to ground; that sketch should alternate the LED between both pins, and both should not be on at the same time. If they are, you have a short.

    #13977
    Profile photo of robert bobbitt
    robert bobbitt
    Participant

    I have firmware B16_32-LCD-112515.ino one question what is this? the code appears to be using same pins for X & Y in this firmware?

    #define DUAL_X_AXIS 0
    #define FEATURE_TWO_XSTEPPER 0
    #define X2_STEP_PIN ORIG_E1_STEP_PIN
    #define X2_DIR_PIN ORIG_E1_DIR_PIN
    #define X2_ENABLE_PIN ORIG_E1_ENABLE_PIN
    #define FEATURE_TWO_YSTEPPER 0
    #define Y2_STEP_PIN ORIG_E1_STEP_PIN
    #define Y2_DIR_PIN ORIG_E1_DIR_PIN
    #define Y2_ENABLE_PIN ORIG_E1_ENABLE_PIN
    #define FEATURE_TWO_ZSTEPPER 0
    #define Z2_STEP_PIN ORIG_E1_STEP_PIN
    #define Z2_DIR_PIN ORIG_E1_DIR_PIN
    #define Z2_ENABLE_PIN ORIG_E1_ENABLE_PIN
    #define FEATURE_THREE_ZSTEPPER 0
    #define Z3_STEP_PIN ORIG_E2_STEP_PIN
    #define Z3_DIR_PIN ORIG_E2_DIR_PIN
    #define Z3_ENABLE_PIN ORIG_E2_ENABLE_PIN
    #define FEATURE_DITTO_PRINTING 0
    #define USE_ADVANCE 0
    #define ENABLE_QUADRATIC_ADVANCE 0

    #13985
    Profile photo of Ryan
    Ryan
    Keymaster

    Did you flash the whole arduino firmware, A common mistake lately is just flashing the .ino? When you flash all the tabs should be open across the top of the arduino window. I can’t see anything wrong in the pictures because they are really small. I see some end stops though, do not connect them until you have it working without them first.

    There is nothing wrong with the firmware it has been around 8 months or so.

    #14117
    Profile photo of robert bobbitt
    robert bobbitt
    Participant

    just received new board combo I can communicate with anduino software but not with repetier and my computer does not have a option for 250000 coms so I set for 115200, does new board have a sketch loaded?

    #14119
    Profile photo of Ryan
    Ryan
    Keymaster

    Yup loaded but it is set at 250000 in the firmware.
    Are you on a Mac?

    #14120
    Profile photo of robert bobbitt
    robert bobbitt
    Participant

    windows 10 surface pro4

    #14127
    Profile photo of Ryan
    Ryan
    Keymaster

    That Should be the default setting in repetier not windows. Does your repetier show that option?

    #14130
    Profile photo of robert bobbitt
    robert bobbitt
    Participant

    yes still same error I would send a SS but surface?!@#! thanks MS “a device connected to system is not functioning”

    #14132
    Profile photo of Ryan
    Ryan
    Keymaster

    Just re flash the firmware after you change the baud rate. It’s not a big deal mac’s use the slower speed.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.