Home / Forum / Getting Started / Z-axis plunges past table at beginning of print

Viewing 5 posts - 1 through 5 (of 5 total)
  • Profile photo of sergei jeltychevsergei jeltychev
    Post count: 0
    #12588 |

    Hi everyone. I built the machine with
    36x36x6 built volume. Loaded marlin available from Vicious1.
    All Steppers work fine aside z and extruder motors getting quite hot.
    Z-motor making weird noise when stop time to time.

    But the real problem is that at the beginning of a print the z is first plunging past the bed.

    Is there a fix in g-code?
    Is there a way to permanently fix zeroing to correct heights?

    All help is much appreciated.

    Profile photo of vicious1vicious1
    Post count: 2642
    #12595 |

    What stepper drivers are you using and what amperage do you have them set at? The zaxis should be roughly half of the X and Y axis.

    As for going past the bed you need to reset the zero before you start a job and make sure your axis is moving in the right direction.

    Profile photo of vicious1vicious1
    Post count: 2642
    #12600 |

    I use the 2250 drivers set to 2A per drivers spec.
    It is weird that the x and y motors stay cool with the same settings but a is getting hot.
    Extruder motor I set to 1A as I just don’t know the specs. Got some generic mk9 and it did not have any spec sheets included, so I just went ahead and reduced the amperage just in case.
    As far as z Plunge, I do reset through LCD controller when machine starts ( and I move my head to desired location first, nozzle just touching the table).
    Still, when process starts, head goes down past table first the raised up and tries to print in the air.

    I do not have end switches installed.
    Overall z is 12″. Frame tube over table (center of lower axis tube) is at 8.75″

    Maybe I have a moving wrong direction?
    How do I switch it backwards? Just flip the plug?

    Thank you much for all the work you out into this project!!!

    2A is the rated max usually meaning they will want to run almost 100C above ambient if I remember right. I would dial that down to 80% or so and go up from there depending on stepper temps while in use. Dial them all down until they are warm not hot, I know that isn’t an exact number but it does seem to be the best way. Not all the steppers get used the whole time so the percentages will vary.

    I’m not sure what could be happening to your z axis you should include some of your beginning gcode, that should so what is going on. How are you generating it?

    • This reply was modified 5 months ago by Profile photo of vicious1 vicious1.
    Profile photo of DavidDavid
    Post count: 1
    #13470 |

    I have the same problem, I think I need to focus on figuring that out, did you ever figure it out? I tried the test file under software in assembly instructions and that seemed to work, but when I take a vector image through the estlcam export for repitere then start the print and it just keeps going down on the x till I have to kill it before it pushes through the table….

    Profile photo of vicious1vicious1
    Post count: 2642
    #13482 |

    @David post the first 30 or so lines of your gcode. If the test file works it just a missed setting somewhere.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.