Reply To: Cannot connect to Ramps/Arduino Mac/Linux/Windows

Profile photo of Patrick

Still not working on my Macbook Pro. Tried installing driver again, using the non-LCD and LCD versions. It verifies correctly but does not upload and will not connect. Anyone able to assist?

Error codes now…

Arduino: 1.6.9 (Mac OS X), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

Sketch uses 102,448 bytes (40%) of program storage space. Maximum is 253,952 bytes.
Global variables use 4,224 bytes (51%) of dynamic memory, leaving 3,968 bytes for local variables. Maximum is 8,192 bytes.
avrdude: ser_open(): can’t open device “/dev/cu.usbmodem1421”: No such file or directory
ioctl(“TIOCMGET”): Inappropriate ioctl for device
ioctl(“TIOCMGET”): Inappropriate ioctl for device
avrdude: ser_send(): write error: Bad file descriptor
Problem uploading to board. See for suggestions.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.