Reply To: 525 XY Tension (Some Bearings Not Touching)

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC 525 XY Tension (Some Bearings Not Touching) Reply To: 525 XY Tension (Some Bearings Not Touching)



1. Electronics and parts. I printed the parts myself and had and Arduino + ramps board already. I’m close to ordering a new ramps board from you, just as a test. I bought the drivers from you to replace the cheap knockoff ones that my ramps board came with. I have these steppers: NEMA 17 76oz/in

I had been using this setup with with the 2’x3′ frame plus old and new middle assembly to 3d print and it had been incredibly accurate. I’ve only recently started to try to mill the large iTopie frame on this new 4’x4′ frame and noticed these new issues.

2. Yeah, it’s really odd. The conduit is all 23.32-23.47mm range. It’s not perfectly round, but it’s not 23.5mm. I measured the conduit from my old frame that was working great and it also was all < 23.5mm. I might go take my caliper to The Home Depot and see if their conduit is closer to size.

I printed out the new middle/z assembly parts right after you published them, but I think before the different sizes were available. Mine all have the letter “c” on them. Yes, just confirmed from the files I generated gcode for C-XY, C-XYZ, and so on. They are the only files with a letter- prefix.

I might try reprinting one of the XY parts to see. I recently moved over to Simplify3D and maybe it will do a better job slicing than Cura did (printed on a Printrbot Simple Metal). I’m use to PLA shrinking if anything with bolt holes and such (also don’t have a heated bed), so for this to be larger is odd. It printed the tension bolt b area on the bed and worked it’s way up. Should I try printing this flipped vertically?

TROUBLESHOOTING UPDATE (my shudder/pop issues is related to electronics or gcode):
Okay, so I’m ignoring the LCD movement. I had read your advice about squaring up the rollers after manually moving and that fixes it so I can mill/draw perfect squares 20mm to 40mm and circles.

I just now took the entire middle assembly apart, reassembled and the problem persists. So I took all of the belts off. From my SD card I ran the gcode I attached to the original post and held my fingers loosely around one of the x and one of the y pulleys. It studders. So I tried the same cut. Leads me to think it is either the gcode or more likely it’s the electronics. I am going to double check my driver voltage.

I took a small video of it in action. You can see it shudder as it moves down the Y axis (at 10s mark) and then again as it’s turning to do the lower portion of the cut it shudders again (at 22s mark). It just jumps back a little in the opposite direction and then continues on. Sometimes it will mess up the cut and then go off into oblivion. Is this thermal shutdown that I’ve read about where there is a tiny delay? I’ll try the old clip on push fan to see if that makes a difference and double check my driver voltage next.

Video of Shudder Issue
Also, I use to use this cooler for my RAMPS board with a fan I bought from you. ramps 1.4 fan clip mount

As part of the wiring cleanup on this new frame I moved to this enclosure with 2 40mm fans I bought from you and have them pulling air out of the case (printed 50mm to 40mm adapters). new ramps enclosure

I am starting to wonder if my previous open with a fan blowing air directly onto the drivers was a better setup and if I’m getting overheating on long x/y operations possibly.

I’m going to setup a test cut that makes 900mm X and then 900mm Y line, then a diagonal cut to the opposite corner. That should isolate things a bit more. If it is overheating then it should be easily reproducible.

Sorry, I know you are really busy answering everyones questions. Thank you for this awesome machine. I’ve used the form and found answers to all of the other issues I ran into, this seems to be the last issue I have, but I couldn’t find anyone having this same issue. I really appreciate your time and this project!