3d Print troubleshoot-

This topic contains 60 replies, has 6 voices, and was last updated by  Walter 1 year, 8 months ago.

Viewing 30 posts - 1 through 30 (of 61 total)
  • Author
  • #7028

    mark leino

    Just got up and running tonight! Started off great, got all the settings loaded into slicer that were posted on the site and it took off and started printing!!! Now, I don’t happen to have a picture on hand, but my prints look like layers of stacked paper, with little air gaps inbetween. I will print out the entire part, but it isn’t very strong. To me, it looks like z is going up to high each step. Also, on each layer, the infill doesn’t quite reach the perimeter. Where do I start looking in my settings to correct the issue? I compared a print from my simple metal to the same print from the mpcnc, and the mp is a bit taller as well, but no wider. Using repetier host, 208 degree with PLA. Using all the parts from the kit, including import extruder.’


    This is so much fun!


    mark leino

    Also, I mounted a dial indicator on my z and moved around, and in a 10″x10″ area, I am leveled to the extruder within .015″ (sorry indicator doesn’t read metric). Also, I have a piece of glass laid down with tape on top of the table for a flatter surface. Prints are sticking better than fine.



    looks like an extrusion multiplier issue to me. PLA usually likes around 95% multiplier. but just keep upping it until it fills in.
    as far as the infill, that can be solved by extrusion multiplier (try that first) if after you resolve that it doesnt work, there is a value called infill overlap. that can help



    You are using my hardware bundle and extruder? How much taller are the parts than they should be? If you have calipers you can tell it to move up or down 20mm and verify the actual distance. If this is wrong the prints will not work. But honestly this should not be wrong if you are using all my parts. Did you change anything?


    mark leino

    I didn’t change anything as far as I know, I did go through and enter all your slicer settings, but when I have gone back to try to change some things around, it doesn’t seem to have any effect on the print. So I’m not sure if I’m not doing things in the right order or not. One thing that seems strange are the numbers at the beginning of the gcode. I will copy and paste a few of the settings from it, maybe it will help. This is all the electronics from your hardware kit. Another thing I noticed, on each individual layer, the perimeter is not touching the infill area in some places…

    external perimeters extrusion width = 0.40mm
    ; perimeters extrusion width = 0.67mm
    ; infill extrusion width = 0.67mm
    ; solid infill extrusion width = 0.67mm
    ; top infill extrusion width = 0.67mm

    Those are from the beginning of the code, not really sure where the .67 is coming from, I haven’t put that into any setting anywhere?

    This next part is from the end.
    avoid_crossing_perimeters = 0
    ; bed_shape = 0x0,200×0,200×200,0x200
    ; bed_temperature = 0
    ; before_layer_gcode =
    ; bridge_acceleration = 0
    ; bridge_fan_speed = 100
    ; brim_width = 0
    ; complete_objects = 0
    ; cooling = 1
    ; default_acceleration = 0
    ; disable_fan_first_layers = 3
    ; duplicate_distance = 6
    ; end_gcode = G91\nG1 -5\nG1 Z5\nG90\nM104 S0 ; turn off temperature\nM84 ; disable motors
    ; extruder_clearance_height = 20
    ; extruder_clearance_radius = 20
    ; extruder_offset = 0x0
    ; extrusion_axis = E
    ; extrusion_multiplier = 1.1
    ; fan_always_on = 0
    ; fan_below_layer_time = 60
    ; filament_colour = #FFFFFF
    ; filament_diameter = 1.75
    ; first_layer_acceleration = 0
    ; first_layer_bed_temperature = 0
    ; first_layer_extrusion_width = 200%
    ; first_layer_speed = 30
    ; first_layer_temperature = 215
    ; gcode_arcs = 0
    ; gcode_comments = 0
    ; gcode_flavor = reprap
    ; infill_acceleration = 0
    ; infill_first = 0
    ; layer_gcode =
    ; max_fan_speed = 100
    ; max_print_speed = 80
    ; max_volumetric_speed = 0
    ; min_fan_speed = 35
    ; min_print_speed = 10
    ; min_skirt_length = 0
    ; notes =
    ; nozzle_diameter = 0.4
    ; only_retract_when_crossing_perimeters = 1
    ; ooze_prevention = 0
    ; output_filename_format = [input_filename_base].gcode
    ; perimeter_acceleration = 0
    ; post_process =
    ; pressure_advance = 0
    ; resolution = 0
    ; retract_before_travel = 2
    ; retract_layer_change = 0
    ; retract_length = 1
    ; retract_length_toolchange = 10
    ; retract_lift = 0
    ; retract_restart_extra = 0
    ; retract_restart_extra_toolchange = 0
    ; retract_speed = 30
    ; skirt_distance = 6
    ; skirt_height = 1
    ; skirts = 1
    ; slowdown_below_layer_time = 5
    ; spiral_vase = 0
    ; standby_temperature_delta = -5
    ; start_gcode = \n
    ; temperature = 212
    ; threads = 2
    ; toolchange_gcode =
    ; travel_speed = 130
    ; use_firmware_retraction = 0
    ; use_relative_e_distances = 0
    ; use_volumetric_e = 0
    ; vibration_limit = 0
    ; wipe = 0
    ; z_offset = 0
    ; dont_support_bridges = 1
    ; extrusion_width = 0
    ; first_layer_height = 0.2
    ; infill_only_where_needed = 0
    ; interface_shells = 0
    ; layer_height = 0.2
    ; raft_layers = 0
    ; seam_position = aligned
    ; support_material = 0
    ; support_material_angle = 0
    ; support_material_contact_distance = 0.2
    ; support_material_enforce_layers = 0
    ; support_material_extruder = 1
    ; support_material_extrusion_width = 0
    ; support_material_interface_extruder = 1
    ; support_material_interface_layers = 3
    ; support_material_interface_spacing = 0
    ; support_material_interface_speed = 100%
    ; support_material_pattern = pillars
    ; support_material_spacing = 2.5
    ; support_material_speed = 60
    ; support_material_threshold = 0
    ; xy_size_compensation = 0
    ; bottom_solid_layers = 3
    ; bridge_flow_ratio = 1
    ; bridge_speed = 60
    ; external_fill_pattern = rectilinear
    ; external_perimeter_extrusion_width = 0
    ; external_perimeter_speed = 50%
    ; external_perimeters_first = 0
    ; extra_perimeters = 1
    ; fill_angle = 45
    ; fill_density = 50%
    ; fill_pattern = rectilinear
    ; gap_fill_speed = 20
    ; infill_every_layers = 1
    ; infill_extruder = 1
    ; infill_extrusion_width = 0
    ; infill_overlap = 15%
    ; infill_speed = 80
    ; overhangs = 1
    ; perimeter_extruder = 1
    ; perimeter_extrusion_width = 0
    ; perimeter_speed = 60
    ; perimeters = 3
    ; small_perimeter_speed = 15
    ; solid_infill_below_area = 70
    ; solid_infill_every_layers = 0
    ; solid_infill_extruder = 1
    ; solid_infill_extrusion_width = 0
    ; solid_infill_speed = 20
    ; thin_walls = 1
    ; top_infill_extrusion_width = 0
    ; top_solid_infill_speed = 15
    ; top_solid_layers = 3

    I will double check that z travel = actual z travel.

    Thanks for all your help



    Looks like you nozzle size might be wrong. Double check

    After each screen hit save, then before you slice make sure you are using the setting you saved. Slicer has a sort of quick change function.
    The 3 red arrows are the names for the 3 tabs in the settings screen, all 3 need to be whatever you saved them as.


    mark leino

    Here is another picture



    The other option is the extruder driver might need to be turned up. Some of the extruder steppers seem to need more power. So if those setting don’t work we can try this next. If the extruder is barely pulling the filament this could be the problem. I have some that need twice the power as normal.


    mark leino

    I will say the extruder does seem like its pretty “weak” compared to my printrbot. That thing will rip it right out of my hand. But I did measure z, and it is moving correctly. I also measured my extruded filament, and its exactly .4mm. Hatchbox PLA filament measures 1.75mm to 1.76mm.

    I will try another quick print just to double check everything after saving everything again.



    Okay try the driver then, I shipped at somewhere around .5v I have one that needs up to .9v.

    Random sorry about that.


    mark leino

    Well unfortunately the driver voltage wasn’t the issue. The print on the left is at .9v (for the sake of trying something) and the one on the right was at .5v. Nothing else was changed, I just printed two in a row and raised the voltage. So guess I need to keep hunting for the issue. Any other suggestions? Thanks for all your quick troubleshooting help, this has been one of the most rewarding projects I have had!



    The dimensions are correct though, so we can eliminate one issue?
    Any other filament you can try? When I worked at robo we got in a batch of ABS marked as PLA, similar issues. or could that be really old PLA exposed to the humidity for a long time?

    Extrusion test, match 100mm on the filament, lift the nozzle off the bed and extrude 100mm and make sure it matches? I hope they didn’t change the drive gear size on me that will be a pain to figure out.


    mark leino

    Yes, the part dimensions are correct coming out correct. Last night when I had that issue I had just opened the garage door, and things were too cold (it was 2 degrees F last night). I keep it about 70 in here normally.

    The filament is brand new, I printed about half the parts out for this machine from it last week and it was the best printing filament out of what I got.

    Extrusion test:
    Well, this was interesting. I raised up 100mm. Extruded 100 manually in repetier, and it looks like about 1000 came out. So then I tried 10, and it just went down to the table and stopped. Strange. When I’m printing though, it doesn’t seem like its using very much filament though. I made a little gear for my printrbot so I could monitor how fast it was using filament, and on this when I have put “marker marks” on the filament it seems to be using it much slower, and adjusting the driver voltage didn’t change that.

    I measured the 1000mm piece of filament that extruded in several places just for the heck of it. It measured from .40 – .50 with .47mm being the average. Not sure if that means anything. I’m still pretty new to 3d printing.



    I was expecting 50mm to be used on the 100mm test. You measured the cold side right, raw filament. It will extrude a bunch so 1000 kinda seems right on the hot side. Your parts look severely under extruded.

    Maybe that one has a .5mm nozzle on it. It should not but give that a try. Change your slicer to .5mm and see if it looks better, that might actually explain the fill not touching the perimeters as well.


    mark leino

    OK- so here is what I found after doing your test right.

    If i extruded 10mm manually from repetier, it would pull in 10mm from the cold side. Extrude 20, it would pull 20 from the cold side.

    Before I did that, I tried using .5 for nozzle size. Made the parts worse, infill further from perimeter. Then I got the bright idea to try .35, yeah it made it better as far as the borders but then I remembered I bought a pack of .4mm drill bits. It fit perfectly into the nozzle.

    This is driving me crazy! Everything seems to be right!



    It has to be a slicer setting. Let me send you some gcode.

    This is set to the origin being in the center of the build plate, so before you hit print center and zero your extruder.


    mark leino

    Ok got it loaded…. This is probably a dumb question but I ran into it earlier when I tried to print from other code… When I get it all loaded and click print, it says “heating extruder”, but never heats it up. How do I make it actually heat it up? When I was running other things through the slicer, it would say heating extruder and actually heat up. Even if I try to manually check it on, it won’t start. What’s going on?



    Oh, do you have a heated bed? That gcode has that in there. I think you can manually delete that in the beginning of the file.

    remove these,
    M140 S44
    M190 S44


    mark leino

    Well it printed nicely. Its a relief to rule out hardware/firmware/extruder issues. Now to try to figure out what the heck is going on in my settings somewhere…. I have gone through them over and over again. Any suggestions? Thanks very much for all your help. Never could have gotten this far without your support.



    mark leino

    I went through and checked every setting, in every profile, and changed all of them to your recommended settings. Still printed badly. So I went and bombed out every config. file that had been saved, and started fresh. Now its printing nicely. Strange. But I really have no idea what was wrong. Its like it had it stuck in its brain to only do one thing, no matter what setting I changed. I reeaaalllyyy appreciate all your help. Can’t wait to show you guys a pic when I get the wiring all done up.



    Sweet! High five! That was crazy, glad you stuck with it. That first print should be a trophy.


    mark leino

    Yeah I took a vacation day today to work on it, my wife thinks I’m crazy! I figured if I could get it printing, then getting the router on there would be a piece of cake! Hopefully this summer I will build another one for the elementary school my wife teaches at, they have a pretty cool technology program she is getting started so I figured I had better help her learn. They already have a makerbot, but it gets used very little. I think next year we are going to do an after school CAD-design-build class for kids who want it, so I need to get myself to a level where I can actually explain how some of this stuff works to others.

    Thanks for your patience.


    James VanDusen

    I ran into this same issue with the test Marvin Keychain…. what config files did you delete? The exact issue is occurring on mine even after repeating the configuration in Slic3r following vicious instructions.

    Vicious… I am using all your hardware as well and its like missing some pieces during layer printing or printing not enough… although I had a solid object, it was very poor.


    mark leino

    Oh yeah that does kind of look like mine

    I went into file explorer and found where the slicer settings were saved. Mine was in the folder made by slicer: C:/ users /lema0905/appdata/local/repetier host

    I deleted every config I made, and went back and entered the posted settings, saving every setting, every screen. Then it magically worked! Also I had another issue going on, z-axis wobble! It’s crazy how such a little movement can cause such a drastic change! That was also making my problem worse. I still don’t quite have it figured out, but its better. I made a coupler out of aluminum and put set screws in it, and i tightened one all the way up, then just tightened the other. By adjusting and tightening them evenly into the rod it improved also. You can see from the pics.


    James VanDusen

    Agreed – that still looks pretty bad – not very high res at all unlike the parts we received… something is maybe different on these latest extruders maybe?
    Attached is my second run… just not good at all… its solid, just poor quality.

    Belts are tight no slippage – very quiet movement actually
    Z is placed onto table before starting print

    I am going to print something more square and see where the issues are… at least can show it more instead of this marvin item.



    Okay so In repetier you have to save every screen or you will lose your settings, and you have to check that it actually saved them. Early on it was notorious for not actually saving your settings. Just go page by page, close repetier then open and double check all the settings. A pain but you only need to do it one time. Then make sure your custom settings are selected on the slice screen.

    As for the z “wobble” I know it matches the thread height but it is actually from a bent allthread. Some times you can just flip it over and it will be better, sometimes you can fix the bend. Also tighten up the z axis bolts to try and keep it a little more steady. If it is bent too bad you will crack you z motor mount. Chased this exact problem at a previous company for months, turned out those 8mm couplers do not work on 5/16 rods. Leaves them uncentered and causes the same issue. That is why I chose to print couplers.


    James VanDusen

    So are you thinking the threaded rod is maybe bent?
    It appears pretty straight, I see no struggle going up or down on it.

    Wish I knew more about this stuff to help troubleshoot, but it is like its maybe not getting hot enough? I see it at a constant 204 degrees while its printing…
    I’m using the common hatchbox brand… red 1.75 PLA.

    I have cleared out the settings and redone them…. NOTE to Mike… renaming that folder did not clear out the settings My Settings or the configured stuff… I will look for it elsewhere.
    But I created 3 new profiles called .27 40% .4 Settings etc and a My Settings and then I just said TEST and all of them following the instructions, all the settings appear to be ok when I load back up the software.

    Here is a screen shot of the printer settings where I matched your screen shot changing the 3600 to 4800 etc… that seemed to make it worse.


    mark leino

    I actually deleted the .ini files from that repetier folder, then closed the folder, went back into slicer, made a new profile and it seemed to help.

    As far as for the threaded rod, it does appear to be a bit bent. I wonder if I were to buy a “straight” 3 foot piece of the threaded rod, and cut a piece off of it, if it would be better…

    Also before you print, click the slicer tab, and be positive that the box “override slicer settings” is not checked. For some reason it always is checked every time I open a new file.


    James VanDusen

    Yes all that appears to be ok…. I even found the location of where our configs are stored:
    In there are 3 folders each with the settings saved from those tabs.
    I removed them and created new ones…

    Didn’t help… I tried printing a more square type shape such as the Corner Block Lock…. it sort of starts out ok… but then skips a lot on the infill etc… I am not familiar enough with extruders to know what’s up…

    Ok Here are ALL the screens of my current setup and profiles (MPCNC)


    James VanDusen

    Could it be the stepper currents like another post I saw?

Viewing 30 posts - 1 through 30 (of 61 total)

You must be logged in to reply to this topic.