3d prints too big

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of Pavel Pavel 4 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29145
    Profile photo of bern
    bern
    Participant

    Got my mpcnc together, I find my 3d prints to big, I calibrated a 20mm cube from thingiverse, my prints were 40mm. In firmware I changed
    #define DEFAULT_AXIS_STEPS_PER_UNIT {200,200,4535.44,200}
    To half: {100,100,2267.72,100} Now i get 19.5mm square cube
    Also now it extrude 100mm filaments..
    Is this the correct way? I did follow the slicer direction here to the repetier host.

    #29155
    Profile photo of Pavel
    Pavel
    Participant

    What drivers are you using? If A4988 then yes, you need to change steps per unit. This drivers only 1/16 microstepping max.

    Try to play with extrusion factor to get right dimension.

    Also check, does your extruder is not skipping steps or pressure of he filament roller is OK.

    #29158
    Profile photo of bern
    bern
    Participant

    Thank Pavel..
    Yes it A4988 chips/ driver, had an DIY delta printer that I move all the electronic to this mpcnc.. I have it at .9v to avoid stepper stuttering/skipping.. hope that is ok, seems the drivers n step motor is running cool.
    With Extruding calibration I’m getting 100mm out when selected 100mm in the repetier host.
    Also I can change the value in repetier host in the eprom config. But when I close it, it doesn’t save the new value, ???, which is why I change it in the firmware.

    #29164
    Profile photo of Pavel
    Pavel
    Participant

    You should set Extrusion Factor in Slicer, because every material needs slight change there.

    Also, your extruder can work ok on free filament run, but stuttering while printing. If you do not hear any stutter noise while printing, then I suggest you, after next print (while nozzle is hot) take out the filament from the extruder and analyze the marks from the extruder’s pinion. They should be clearly visible without any skipping.

    Of course, I suppose, that your filament diameter setting is right (measured with caliper).

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.