“communication timeout reset send buffer block” ERROR when using DC spindle

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC “communication timeout reset send buffer block” ERROR when using DC spindle

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of wwkzf wwkzf 3 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #27111
    Profile photo of wwkzf
    wwkzf
    Participant

    Hi all.
    My spindle is 52mm made in china 500w DC motor, when it is on, a “communication timeout reset send buffer block” will appear after motor is on. I tried run .nc file without motor on, it is OK, so the problem must be interfere from DC motor, it has a brush, may generate spark. I also tried wrap the arduino box with foil, does not work ether.
    I wonder, there are lots of people in this site using same DC motor, how do you guys solve this problem?

    #27114
    Profile photo of Bill
    Bill
    Participant

    I would start by changing the stepper wires to shielded, then isolate the power supply for the spindle from the power supply for the RAMPS. The power supply generating the DC for the spindle is probably where the noise is coming from, and the wiring for the steppers is acting as an antenna to pick up that noise. Oh, and ground only one end of the shield for the stepper wires.

    #27143
    Profile photo of Ryan
    Ryan
    Keymaster

    Nice Bill, I didn’t know about the only grounding one side thing, but it makes perfect sense. I love learning new stuff.

    #27527
    Profile photo of wwkzf
    wwkzf
    Participant

    Thank you very much, I will try to isolate motor first.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.