Compiler error

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Bill Bill 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30207
    Profile photo of Steven Weeks
    Steven Weeks
    Participant

    I’m trying to flash an old RAMPS 1.4 I already had. I have the software from this site (no changes) and I using the Arduino web ide. Using a MAC and Chrome. The u8glib library is installed (as best I can tell). I know how to program in C, but am clueless about the Arduino environment. I get the following error. I’m sure it is something dumb I’m doing, but have no idea where to look.

    Can someone point me in the right direction?

    Thanks,
    Steve

    arduino-builder/arduino-builder -compile -core-api-version 10611 -build-path /tmp/912155998 -hardware arduino-builder/hardware -hardware arduino-builder/packages/cores -tools arduino-builder/tools -tools arduino-builder/packages/tools -built-in-libraries arduino-builder/latest -libraries /tmp/704091963/pinned -libraries /tmp/704091963/custom -fqbn arduino:avr:mega:cpu=atmega2560 -build-cache /tmp -verbose=false /tmp/704091963/RC7_MPCNC_LCD_9916

    /tmp/704091963/RC7_MPCNC_LCD_9916/RC7_MPCNC_LCD_9916.ino:39:12: error: missing binary operator before token “(”

    #if ENABLED(ULTRA_LCD)

    ^

    /tmp/704091963/RC7_MPCNC_LCD_9916/RC7_MPCNC_LCD_9916.ino:61:12: error: missing binary operator before token “(”

    #if ENABLED(DIGIPOT_I2C)

    ^

    /tmp/704091963/RC7_MPCNC_LCD_9916/RC7_MPCNC_LCD_9916.ino:65:12: error: missing binary operator before token “(”

    #if ENABLED(HAVE_TMCDRIVER)

    ^

    /tmp/704091963/RC7_MPCNC_LCD_9916/RC7_MPCNC_LCD_9916.ino:70:12: error: missing binary operator before token “(”

    #if ENABLED(HAVE_L6470DRIVER)

    ^

    exit status 1

    #30219
    Profile photo of Bill
    Bill
    Participant

    Do a search and find where the ENABLED() macro is defined.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.