Cut and travel movements too large (1.25X)

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Cut and travel movements too large (1.25X)

This topic contains 3 replies, has 3 voices, and was last updated by  BT 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #36242

    JMW
    Participant

    Hi,

    I’ve just finished my first MPCNC. The CNC works great overall – it’s easily controlled and square but all of my movements are too large by a factor of 1.25 (e.g., a 10mm movement is 12.5mm, 10cm movement is 12.5cm, etc.). I cut a perfect circle in acrylic, and it was 125% the size that it was shown in Repetier-host.

    This includes BOTH the travel movements (via manual control in Repetier-host) and cut movements. I’ve doubled checked my drawing measurements, and they are preserved accurately in both ESTLcam and Repetier-host; only the physically cut pieces are too large. Any idea on what could be causing this, and how to fix it? I’ve reviewed my entire set-up and everything appears to be assembled correctly.

    Parts were not bought from here, but identical parts were sourced from other places:

    1. Using NEMA17 48MM 1.68A (1.8 degree) stepper motors controlled by a Ramps 1.4 stack and DRV8825 drivers, that have been appropriately voltage adjusted.
    2. I’ve confirmed that the RAMPS jumpers are correctly in position beneath the drivers for 32nd stepping.
    3. There is a 100k Ohm resistor in the TO position on the RAMPS 1.4
    4. I’m generating my CNC code with ESTLcam, and controlling the MPCNC with Repetier-host following the guides from here.
    5. My Arduino/ramps has been flashed with the most recent firmware from here (https://www.vicious1.com/wp-content/uploads/2017/05/MPCNC511_GLCD.zip)

    Thanks for the help!

    #36249

    Ryan
    Keymaster

    If you have the most recent firmware, no need for the resistor.

    Count the teeth on your pulleys I bet you have 20 instead of 16 teeth.

    #36251

    JMW
    Participant

    Well,

    That’s the problem! Thanks for the help. Case closed.

    #36252

    BT
    Participant

    Sounds like you have a 20T pulley instead of a 16T pulley on your motors. That will give you 25% more distance per stepper revolution.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.