enable z probe, printing

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC enable z probe, printing

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of bern bern 2 weeks, 3 days ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #29327
    Profile photo of bern
    bern
    Participant

    hello.. my setup mostly a 3d print..
    looking in enabling z probe for bed leveling using a proximity sensor..
    want to make sure i uncomment the correct code in the rc7 firmware..or any that i should..
    newb here learn as i go..hehe

    // A Fix-Mounted Probe either doesn’t deploy or needs manual deployment.
    // For example an inductive probe, or a setup that uses the nozzle to probe.
    // An inductive probe must be deactivated to go below
    // its trigger-point if hardware endstops are active.
    //#define FIX_MOUNTED_PROBE (uncomment this)

    this is already enable, use the z min pin for the proximity sensor?
    // Enable Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN to use the Z_MIN_PIN for your Z_MIN_PROBE.
    // The Z_MIN_PIN will then be used for both Z-homing and probing.
    #define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN (already uncomment)

    enable this..
    Bed Auto Leveling
    // @section bedlevel

    //#define AUTO_BED_LEVELING_FEATURE // Delete the comment to enable (remove // at the start of the line) (uncomment this)

    // – Prevent Z homing when the Z probe is outside bed area.
    //#define Z_SAFE_HOMING (uncomment this)

    thanks..

    • This topic was modified 2 weeks, 3 days ago by Profile photo of bern bern.
    • This topic was modified 2 weeks, 3 days ago by Profile photo of bern bern.
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.