Estlcam 2.5D tutorial?

New Home Forum Software Development Estlcam 2.5D tutorial?

This topic contains 39 replies, has 5 voices, and was last updated by  Ryan 1 year, 9 months ago.

Viewing 30 posts - 1 through 30 (of 40 total)
  • Author
  • #4641


    Hi to all,

    i’ve seen this wonderful video ( and i would like to create something similar (sure for start something difficult less :D)

    I’ve tried to use EstlCam (this is the software used to make it ?) but i have some difficult to create 2.5D model (if i have to create a simple profile ok, but what if i have to create 2.5D ?)

    There are some guide for this topic ?

    What is the source file to create 2.5D ? A flat image or a model like in a 3D printer ?

    Thanks a lot to all!



    If you use a .STL file, like a 3D printer a whole new menu opens up. you should be able to get it from there. There are a few things you can do to optimize the speed but a little googling and you should be able to get a decent part out without it.

    I will make a 2.5/3D walk through in a week or two.

    Ask if you don’t understand anything.



    i’ve done as you suggest and look some videos.

    I’ve setup EstlCam as “Z-Axis origin: Material Upperside”, that because my stock is 10mm taller and my model is 7mm (so i want to start cutting from top to bottom).

    The problem now is with RepetierHost, because when i press “Print” Repetier first go at home (and Z Axis have home on bed).

    What modification i have to do in Repetier to say “When i press print, start cut from where you are?

    I’ve also tried to setup EstlCam as “Machine Bed” but in this way first it cut the bottom of the piece and later go up (this is wrong because in this way Dremel cut too much material each step).



    I too do not fully understand how to fully control where it starts. I currently have it as the 0.063″ clearance and start at origin.



    Did you solved this problem ? I’m trying all configuration but every time it go first home and later start to cut (and sure, the drill is on the bed and not in top of surface!)



    I’ve finally resolved!!!! I was enabled min_software_endstop on my Marlin, after disable it (and sure, i move my machine in the correct position and reset home) all go fine!!!!

    I’ve tried to cut my first part and the result is…… very bad 😀 😀

    In your video ( did you have used Roughing and finishing togheter ?

    I’ve cut my all part with only finishing but in the last step, machine have started to cut a lot of material (0.5 mm!!!)

    I think a tutorial on how make great part will be aprecited to all 🙂



    You should not be homing. You put the tool right where you want to start. And hit go.

    If you use end stops you need to position them so home is whete you want it to start.

    You should Only use end stops if you are changing tools and the home should actually be offset and you need a z touch off.

    I will try and make a walkthrough this evening.



    You should not have had to change anything in marlin if you are using mine.

    Yes, rough and finishing in the same gcode. You rough down to a minimal amount of material with a 45% stepover and then finalize with a 1%-10% stepover depending on desired finish.



    Unfortunally i cant use it because i have 8mm 1,25 threaded rood but i have A4988 driver (with max 16th steps) and T2.5 timing belt with 16th Tooth Pulleys 🙁

    Looking in your configurations (here on site), i dont find one with this characteristics.

    However, now all go fine :)))

    I will wait for some tutorial on how to use EstlCam with .stl and have a better result then mine :)))



    You should start with my beta firmware and just change the steps per mm. I think the accelerations and speeds will hold up. At 16th steps you can rapid faster but I don’t recommend it.



    Unfortunally this driver dont go at 32th steps… i need to buy other to increase steps…..

    Where i can found the beta firmware ?

    However right now i’m happy to has done the first part, later maybe i will have better results 🙂



    16th steps are fine. I use the other drivers for different reasons.

    firmware –



    ok, you did found another tester 🙂

    I will change the parameters for my belt/threaded and i let you know!



    Uploaded th firmware and modified some axis direction (just because i have pinned differently my motors).

    I’ve changed steps as (like prusa calculator says

    DEFAULT_AXIS_STEPS_PER_UNIT {80.0, 80.0, 2560.0, 90.0} // Belt T2.5 with 16th

    I’m not more confident about the third parameter, i’m trying to up Z axis to 10mm but i think him go up to 8.

    However, the script go well (as you said, with the first script i notice a very hard break about the motors).

    Now i will try to mill with a Dremel 3mm drill.






    For your 8mm/1.25pitch threaded rod your firmware should have:
    Z Microsteps/mm = (16Microsteps/Step)(200 Steps/Revolution)(1Revolution/1.25mm) = 2560 Microsteps/mm.
    So you do have the correct value. Are you sure about your Z measurement?



    Backing in topic, i have a model with a phrase (downloaded here and i’ve setup EstlCam like this:

    Tool diameter 3 mm
    Step over 80%
    Depth per pass 1 mm
    Allowanve 0,30mm
    Feddrate 15,0 mm
    RPM 10k

    Stepover 2%
    allowance 0
    Feedrate 10,0mm

    Computing precisin 0,05mm

    With this configuration (that will need 2,5 hours to complete the work!!) the phrase Kiss is veeeeerrryyyy smooth and pratically collapsed -> not very slim like in the model..

    The three line above Kiss disappear

    The last phrase Army disappear too…



    Hi steve,

    i’m almost sure about the measure because i have a wood 10mm (1 cm ) taller (measured with caliber) and after in Repetier i press plus 10 on Z axis, this piece dont fit under the Mill.

    It remain 0,3mm under the top surface of the wood



    Put some calipers on your tool, is it 3mm exactly? Did you follow the estlcam walkthrough for all the basic settings like gcode output units?

    Roughing step over shouldn’t be any higher than 45%.

    Sounds like your z steps might be wrong, or wrong output units. Can you upload a picture, that makes it much easier to see whats going on.



    Yes, i’ve measured the mill again and it is 3mm.

    I’ve follow the instruction and Preset is set to Marlin with length unit “Millimeter” and Feed Unit “Millimeter per Minute”.

    I’ve tick Use arc and I/J coordinates are relative.

    This is the result: null

    Is totally unprecise but this depends to the bad wood and the stock has moved on finishing 😀

    However, i just look at the phrase Kiss, as you can see this is “fat”.

    The result you see in this pic is exactly what i see on RepetierHost preview.



    okay, so that isn’t really a 3D part it would work much better as a 2.5D part. I converted it for you as a 3D so you can see how it works. Try this so we can figure out were the problem really is.

    I made this so you should start the tool on the surface of the piece in the bottom left corner.

    Run my gcode




    Ok… i’ve imported it in RepetierHost and now all are pretty defined…!!!!!

    The original workpiece is 15mm taller (if i remember well) so i have used netfabb to slim it and make 5mm taller (just to be faster).

    Right now i cant run in the real machine because 2.5 hour is a lot, however i think the workpiece now will be fine!!!!

    How you have converted it from 2.5D to 3D ? Because if i set EstCam as the image you sent, i do not obtain your result…. but again “fat” letter…..



    I’ve tried to simulate your gcode now but unfortunally my stock is too little (depth will be ok but length is few), so i cant run it right now :((

    I’ve a Dremel 3000 and i think that 4mm depth on roughing is too much for this machine :)))

    When you can, can you explain me how did you made this gcode ?

    Maybe i can try to find a smaller model so i can try it 🙂



    All the setting I used are in that screen shot. Did you try using those settings?
    When you open the .stl you can adjust the size before that settings screen.



    Exactly the same settings except for edges and this is the result……



    What seems wrong with that it just looks really small? Run the same settings on a bigger version. See if it looks different.



    If i expand it till 20cm (in the first screen) i obtain a most detailed version….

    The original version is 65mmx67x15 (that will be perfect for me…) and if you open the original file in EstlCam (without modify the dimension) i obtain “fat” phrases and the lines above Kiss disappear…. but in the original .stl file is pretty defined.

    So… the only way to obtain a good results…. is to make it 200cmx200cm or little less…. ?

    I just would like to obtain the same result in 65x67x15 too…..



    Unfortunately level of detail comes down to bit size. With a 3mm end mill all x and y corners will get a 1.5mm radius.

    When you get the hang of things a bit more, you can rough out most of the wood with a large mill, then do the final pass with a smaller one for more detail and faster milling times.

    If you check out some big machines youll see they actually have a turrent of bits, up to 30 or so. All to achieve different things.they will typiccally use 5 or so different bits per part.

    Take it slow, make a few cuts, try some different objects. You’ll learn quick. The one you chose to learn on is actually a 2.5D part and actually not very suited for milling. I need to find a cool part amd do a walkthrough. If you check the videos page you’ll see a new video where he made a rose relief and changed bits in the middle. The part came out great. Might give a better inderstanding of what I’m try to describe.

    Feel free to ask questions.



    I’ve tried to change tool for roughing (5mm or 8mm) and getting more details in finishing but it is even fat 🙁

    The only way is make the model bigger…. i was thinking that making all with a 3mm was help to have better details… I was looking your video where you drill an half “donut” ( and this is small and pretty defined…. maybe just because the shape is simple..

    So you suggest me to start first with “flattern” image (like this ) and create on “hand” all the cut i want ?

    I’ve choose this model because i was thinking it was simple to drill… no circle and only few parts to cut…

    Maybe right now is no possible to create a model with small dimension and drill it…. 🙁

    Now i go to see your video.



    I’m not understanding this last post.

    You should try a different part, that kiss badge isn’t working for you come back to it later when you understand the setting a little better. What else would you like to make and I can give you setting for it?

Viewing 30 posts - 1 through 30 (of 40 total)

You must be logged in to reply to this topic.