estlcam and steps/mm z-axis

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC estlcam and steps/mm z-axis

This topic contains 2 replies, has 2 voices, and was last updated by  doc 8 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #26465

    doc
    Participant

    the settings I am using for x and y axis are perfectly dialed in; however, the z-axis is not working properly (stock 5/16 threaded rod from vicious). I’ve tried 1/16 and 1/32 with proper calculation (from reprap) for the steps per mm (something like 4535 when in 32).

    estlcam will display I have moved the z axis over 20mm for just as little as 0.2mm. nothing is binding, the axis moves smooth in both directions. I even tried a value of 800 like vicious did (his post in another thread re: estlcam and mpcnc) – the z axis barely moved with that value…

    I should point out that I am using estlcam to drive the machine as well (flashed).

    Any thoughts?

    #26483

    Ryan
    Keymaster

    Have a second look at that post, 1/4 stepping, jumpers are shown 800.

    Estlcam with experimental Arduino Mega2560 / Ramps 1.4 support


    From there if it is still wrong you can do the standard calibration math to fine tune it, but that was dead on for me.

    #26493

    doc
    Participant

    thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.