Estlcam with experimental Arduino Mega2560 / Ramps 1.4 support

New Home Forum Software Development Estlcam with experimental Arduino Mega2560 / Ramps 1.4 support

This topic contains 178 replies, has 46 voices, and was last updated by Profile photo of vicious1 vicious1 16 hours, 42 minutes ago.

Viewing 30 posts - 121 through 150 (of 179 total)
  • Author
    Posts
  • #23391
    Profile photo of Christian Knuell
    Christian Knuell
    Participant

    Hi,

    I’ve just uploaded beta version 9.037 with support for individual feeds for X/Y and Z.
    This should hopefully solve the issues with Marlin.
    (Make sure to download version 9.037 – not 9.018 and start “Estlcam V9 beta” not “Estcam V9” if both versions are installed)

    Please let me know if it works as desired. And if someone sends me a settings file I’ll include it as preset with one of the next updates (I can’t test it myself as I don’t have the hardware and software).

    Christian

    Attachments:
    #23498
    Profile photo of jimmystanley37
    jimmystanley37
    Participant

    i am learning pretty fast, and liking the ESTLCAM, and the following it has here. I seem to be having issues with transferring my desired design to cut into estlcam and getting the correct dimensions. i have a build area of y=300mm, x=550mm, and z=about 200mm. i built a model that i wanted to cut into my waste board of T-Slot holes. i measured in sketchup but the same measurements don’t seem to translate to ESTL cam as it tries to cut much larger than my build area. is there something i am doing wrong when i import the file from the sketchup save?

    #23499
    Profile photo of vicious1
    vicious1
    Keymaster

    You have to pay close attention to the units you saved it in and match them to the units you import it as. Check out the estlcam basics page for a quick way to use the grid to double check you dimensions.

    #23500
    Profile photo of jimmystanley37
    jimmystanley37
    Participant

    thanks, will report back tomorrow with if it was something goofy i did.

    #23503
    Profile photo of jimmystanley37
    jimmystanley37
    Participant

    is there a ruler tool in estl cam that shows the actual size of the object, other than the grid? i have the grid open, but it don’t seem to have ruler markings telling me how big the object is.

    #23523
    Profile photo of Christian Knuell
    Christian Knuell
    Participant

    Hi,

    you can measure distances with the middle mouse button

    Christian

    #23524
    Profile photo of jimmystanley37
    jimmystanley37
    Participant

    Christian Knuell, Thanks, i really need to watch all your tutorial videos. i’ll make time over the next few days. Thanks for answering questions that i should have been able to figure out myself.

    #23525
    Profile photo of vicious1
    vicious1
    Keymaster

    Heck I didn’t know that. I will add it to the basics page so we don’t forget…

    #23557
    Profile photo of Steve
    Steve
    Participant

    Hey Christian,

    Thank you again for the update. I have a couple of feature questions:

    * The new version will not allow me to open projects created in older versions. Is there a workaround?

    * Is there an “Undo” function hiding somewhere? I cannot find it and tried the ubiquitous Ctrl+Z to no avail. I hate having to start from scratch if I make a small error.

    * The font selection in the text dialog no longer displays a representation of the actual font. They all look the same from within the new version. Is there a fix? I have been keeping the fonts.cpl open so I can pick fonts.

    * Also in the Text function, If I have moved or rotated a text object and then I select it again later the move or rotation is undone or changed. I also have had several instances where it duplicated the object when I re-applied the move/rotate. Any suggestions for this?

    Thank you.

    Stephen

    #23574
    Profile photo of Steve
    Steve
    Participant

    Let me jump in JimmyStanley,

    I have a similar issue. By using the grid in Estlcam I can see that DXF and SVG files that I pull in are roughly 3.5 times the size that I created them in Inkscape. I have all of the document defaults set to mm for measurement in Inkscape.

    I have used Inkscape to draw other projects for the laser in the past and scale has never been an issue.

    Now I turn the grid, in Estlcam, on and resize everything that I bring in from Inkscape.

    With all of the unit measures in document properties set to mm and mm settings in Estlcam where should I be looking for a solution?

    Thanks.

    S.

    #23575
    Profile photo of vicious1
    vicious1
    Keymaster

    I would start here.

    Attachments:
    #23640
    Profile photo of Marvin
    Marvin
    Participant

    What kind of output is the spindle ? 5v,12v ect I would like to at least use it to turn laser on and off if possible

    #23641
    Profile photo of Marvin
    Marvin
    Participant

    Is it possible to use aux2 pin 44 as a ttl 0v to 5v adjust laser power setting if we could add a tool setting for laser for power 0-255 that would allow to adjust laser power or even for now a on and off that I could connect to the laser 12v so it dos not burn during travel moves.
    If this can be don I will gladly donate some more money as I understand that time is money and appreciate everything you are doing and it will save me from purchasing laser software. I have come to the point I prefer to solely use Estlcam.

    Video Explanation

    https://www.youtube.com/watch?v=HqE_J9aoHNU

    May GOD Bless you
    Thank you for your time
    Marvin

    Attachments:
    #24025
    Profile photo of Steve
    Steve
    Participant

    Hey Christian,
    Thank you again for the update. I have a couple of feature questions:
    * The new version will not allow me to open projects created in older versions. Is there a workaround?
    * Is there an “Undo” function hiding somewhere? I cannot find it and tried the ubiquitous Ctrl+Z to no avail. I hate having to start from scratch if I make a small error.
    * The font selection in the text dialog no longer displays a representation of the actual font. They all look the same from within the new version. Is there a fix? I have been keeping the fonts.cpl open so I can pick fonts.
    * Also in the Text function, If I have moved or rotated a text object and then I select it again later the move or rotation is undone or changed. I also have had several instances where it duplicated the object when I re-applied the move/rotate. Any suggestions for this?
    Thank you.
    Stephen

    #24026
    Profile photo of Steve
    Steve
    Participant

    Note regarding the 9.037 Beta:

    I gradually increased the rapids settings from 2200 & 450 to 2500 & 550 and experienced a Z axis crash. I backed the values down to 2400 & 480 and, so far, it has been ok.

    #24027
    Profile photo of vicious1
    vicious1
    Keymaster

    The max speed is dictated by the firmware depending on which versi9n the max for the z axis is 510.

    #24043
    Profile photo of Hansang
    Hansang
    Participant

    Hello Christian, First of all, thank you for supporting MPCNC!

    I am currently using Surface Book with Win 10 x64. The default resolution size is 3000 X 2000 with “Size of text, App and other items) set to 200%. This is the default and recommended setting for Surface Book.

    I noticed that in version and 9.018 and 9.037 beta, the shape dialogue boxes are always cut.

    I don’t have this problem when I click on any of the settings in File, View, Register, Setup, and Help menu.

    And +1 on wanting an UNDO function!!!!

    Dialogue box cut in half

    and

    Dialogue box cut in half

    PS: Just tried with text size to 100% and it made no difference. I exited and restarted the program just to make sure.

    #24133
    Profile photo of Christian Knuell
    Christian Knuell
    Participant

    Hi,

    the scale function of Win10 seems to mess up several things, especially with dual monitor configurations. I’ll try to solve this once I’ve finished my current to do list, but it is difficult as the very last thing I’d like to do is to change my development environment from Win 7 to Win 10.

    Christian

    #24135
    Profile photo of Jamie
    Jamie
    Participant

    Christan,

    The independent travel speed settings you added in 9.037 seem to be working fine, many thanks.

    Jamie

    #24202
    Profile photo of Tony
    Tony
    Participant

    Does the beta support end stops, touch plate or surface mapping at this time?

    #24273
    Profile photo of Christian Knuell
    Christian Knuell
    Participant

    Hi,

    the beta has full functionality but may still be a bit buggy.

    Christian

    #24320
    Profile photo of Tony
    Tony
    Participant

    Thank you Christian. I purchased Estlcam before I even had my MPCNC, and have continued to be impressed with it. Hoping to convert some at our makerspace over to using it as well once we build an MPCNC there.

    #24324
    Profile photo of ManuCNC
    ManuCNC
    Participant

    Hello Christian, as well as thank the Beta version of your software I have tried to empty toolpath today ..
    I wanted to ask how you can contribute to the Italian translation of the software
    Thank you

    #24325
    Profile photo of Steve
    Steve
    Participant

    Hey again Christian,
    Thank you again for the update. I have a couple of feature questions:
    * The new version will not allow me to open projects created in older versions. Is there a workaround?
    * Is there an “Undo” function hiding somewhere? I cannot find it and tried the ubiquitous Ctrl+Z to no avail. I hate having to start from scratch if I make a small error.
    * The font selection in the text dialog no longer displays a representation of the actual font. They all look the same from within the new version. Is there a fix? I have been keeping the fonts.cpl open so I can pick fonts.
    * Also in the Text function, If I have moved or rotated a text object and then I select it again later the move or rotation is undone or changed. I also have had several instances where it duplicated the object when I re-applied the move/rotate. Any suggestions for this?
    Thank you.

    #24340
    Profile photo of Christian Knuell
    Christian Knuell
    Participant

    Hi,

    old files unfortunately cannot be opened – there will also be no workaround available because the file format changed drastically.

    Undo is only available for a few actions – e.g. if you create shapes manually you can undo every step with the backspace key. If you mess up something just delete the affected object – but this should rarely be necessary as all parameters can be changed at any time to new values.

    Font selection list is fixed with version 9.038

    Text objects are special – they will always return to their start position for editing.
    Unless you select “explode text object” – in this case all letters become individual objects and can be moved wherever you like – but then the text itself cannot be changed anymore.

    Christian

    #24382
    Profile photo of Bill Branan
    Bill Branan
    Participant

    Homing Problem: I’d like machine to home only to x & y limit switches. I have both z axis switches disabled and not connected and of course reflashed the Arduino. EstlCam still wants to home z where the z axis continues up and cannot be stopped except with power or reset. It worked as expected with the z axis limit switched connected. . A bug or am I doing something stupid. EstlCam v9.018 Ramps 1.4

    #24394
    Profile photo of Barry
    Barry
    Participant

    @Bill, just use the X home and Y home buttons. You’re lucky, if I hit Z home, it goes down, which can tear apart the motor mounts!

    #24423
    Profile photo of ManuCNC
    ManuCNC
    Participant

    I ask you one thing,
    setting in the CNC controller card do not understand why there is the note to set the steps to 1600 ..

    Use nema 17 1.8deg/step then with 200 steps per revolution and in general have 160step to make 1 mm(with my pulley)

    If imposed in 1600 then I should put 8mm?
    Thanks for the clarification

    PS:
    I wanted to ask how you can contribute to the Italian translation of the software?

    #24684
    Profile photo of Glenn
    Glenn
    Participant

    Just building my first machine. I had loaded Marlin Firmware already on my Mega/Ramps 1.4 w/ 12864 LCD Controller. Everything seems to work well(Still waiting on motors and other small parts) but i would love to be able to use the Estlcam firmware and have access to controlling the machine by PC as well.

    My question is: Can i use the LCD with the current Estlcam firmware which has Error, Probe and Spindle features on those pins? Or is it a one or the other type of choice?

    thanks for a fantastic project with MPCNC and the integration of Estlcam software

    #24702
    Profile photo of Matt
    Matt
    Participant

    Now everyone has tried Estlcam deeper, could someone help me and give a basic parameter setup so i can try to drive my CNC with Estlcam please ?

    I ve built the latest version with all the basic hardware Vicious is recommending: Nema 17 and 8mm threaded rod for the Z axis, gt2 16t pulley, 2mm belt. Actually everything is set up with the recommended parameters in the build assembly (32nd stepping using DRV8825).

    I am really lost when it comes to put the right values in the different field Extlacam is asking before programming like Steps per revolution and Distance per revolution, Acceleration distance, Inertia….
    Also i don’t want to put the Z in 1/4 stepping mode…. is it possible to stay at 32nd stepping mode on all axes ?

    Thanks for your help guys 😉

    Matt

Viewing 30 posts - 121 through 150 (of 179 total)

You must be logged in to reply to this topic.