Home button in Repetier, moving x and y without power, lcd not doing much

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Home button in Repetier, moving x and y without power, lcd not doing much

This topic contains 15 replies, has 6 voices, and was last updated by Profile photo of Ryan Ryan 1 month, 1 week ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #29761
    Profile photo of Zach T
    Zach T
    Participant

    1. In Repetier-Host I am able to move the axis around without issue. Do I need to worry about the home button? The guide doesn’t say anything about it I’m assuming not. I’m guessing it only works with end stops. I see on the forums not to worry about the end stops and to just position it manually where you want 0,0 which leads to the second question.

    2. Does it hurt to move x and y without disconnecting the motors? I say this because the motors feed back electricity to the controller when moved manually. I’m worried about frying something when I go to position for a cut.

    3. The lcd doesn’t seem to show any information other than the ip address it gets from my laptop. It turns on and I can move through the menus, but other than that I can’t control the cnc in any way. I don’t have a sd card in it yet if that matters.

    #29766
    Profile photo of Brian
    Brian
    Participant

    Correct, the home button would only be used with endstops. As long as you dont move the axis super fast you should not have issues moving to your desired start position. And you should be able to move the axis etc threw the LCD screen. I don’t use one currently, but I know you should be able to.

    #29767
    Profile photo of Barry
    Barry
    Participant

    It’s easier to move with repetier than the lcd, but you can move with either. Like Brian said, don’t move too fast manually and it should be okay.

    #29774
    Profile photo of Ryan
    Ryan
    Keymaster

    What lcd, can you put up a picture.

    #29777
    Profile photo of AmperCZ
    AmperCZ
    Participant

    Don’t move your machine manually – it will break your square settings and you will get baaad surprise (just as me today). And I have LCD, I was just too lazy. I have to update my Marlin fork (originally made for X/Y double steppers in extruder sockets on RAMPs) to have more reasonable menu. Like home on main menu and so

    #29789
    Profile photo of Zach T
    Zach T
    Participant

    Thanks for the advice guys.

    The lcd I have is the one sold on this site. https://vicious1-com.myshopify.com/collections/3dprinter-parts/products/full-graphic-smart-controller-big

    #29792

    You can move by hand your axis, no problem. Just not move it at insane speeds, otherwise it can damage your drivers.
    Try to move the axis by grabbing the middle of it, so it won’t screw up the squareness too much.

    #29793
    Profile photo of Ryan
    Ryan
    Keymaster

    You kind of need to give more information. Asking a bunch of questions is slow. Could you run through the questions in the sticky post. I have an idea of what is wrong but need more info.

    Sounds like you are not running my firmware or you would have a normal screen? what do you have, where did you get it, ect. Pictures really help as well. IP on the LCD, it should be blank or printing info, never heard of an IP on it.

    #29810
    Profile photo of Zach T
    Zach T
    Participant

    1) Did you buy everything from here?
    Yes.

    a)If you didn’t or changed some things please don’t leave out any details and include what firmware you flashed.

    I didn’t change anything. I assumed it came pre-flashed with the correct firmware.

    2) Are you using end stops?

    No.
    a)If so please disconnect them.

    3) Mac or PC?

    PC Windows 10.

    4) Include a picture so obvious errors might be spotted.
    Attached. The cable on the right is my laptop power cable.

    It says Vicious and has the logo when I power it on. My previous post has listed exactly what I purchased. The ip only shows up when the pc is hooked up.

    I’ve attached two pictures. I tried to catch the Vicious logo, but missed it and ran out of time before work. I’ll take another picture this evening when I have more time. You’re seeing the screen right after the Vicious logo and the main screen. The x, y, and z alternate with ? indicating it’s not communicating I’m guessing.

    #29827
    Profile photo of Ryan
    Ryan
    Keymaster

    Whoa, I have never seen that.

    Does it work when unplugged from the laptop?

    The question marks are normal.

    #29835
    Profile photo of Zach T
    Zach T
    Participant

    It works just like it does when plugged into the laptop minus the ip. Maybe I just don’t know how to use it to manually move things. How do you select the x or y axis to move? Turning the knob on the main menu doesn’t do anything. All of the menus seem to be for settings and not for manually moving things. I’m probably just missing something simple.

    • This reply was modified 1 month, 1 week ago by Profile photo of Zach T Zach T.
    #29856
    Profile photo of Ryan
    Ryan
    Keymaster

    push the button (knob in), a menu pops up, select prepare, push the button, select move axis, push the button.

    #29870
    Profile photo of Zach T
    Zach T
    Participant

    Yup that did it.

    One more question. Is the ramps board setup to handle being powered from the ac adapter and the usb plug at the same time? Because whenever I turn it on with the ac power and then plug in the usb it resets the lcd which means it’s being powered from two separate sources. I can cut the power and ground of a usb cable if need be, but if it’s designed to handle this power setup I won’t bother.

    #29871
    Profile photo of Ryan
    Ryan
    Keymaster

    A/C adapter meaning the green plug? Never use the barrel jack or you will blow your arduino.

    Plugging in the arduino to the usb resets it because it is trying to connect it should not be a power thing at all.

    #29880
    Profile photo of Zach T
    Zach T
    Participant

    Yes the green plug. If I plug the usb cable in as the only power source it turns on the arduino and the lcd.

    #29884
    Profile photo of Ryan
    Ryan
    Keymaster

    Yup both ways should work, you just won’t be able to move the steppers on USB alone.

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.