How to wire linked stepper motors to Ramps

New Home Forum Mostly Printed CNC – MPCNC Advice – MPCNC How to wire linked stepper motors to Ramps

This topic contains 2 replies, has 2 voices, and was last updated by  John 8 months, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #29633

    John
    Participant

    I’ve done a lot of looking at wiring diagrams for ramps boards but non seem to break out the information I need to wire these stepper motor I’m planning on buying from eBay.

    While the description does mention which is the positive and negative wire of each coil, the Internet hasn’t made clear which end of the coil needs to be connected to what pin of the ramps board.

    does anyone know where I might be able to find the answer or even have the answer themselves?

    Any and all help is appreciated as this is really the final hurtle for me to over come in the assembly process. A next comes running. If there are any guides on this please feel free to point me in that direction as well.

    Thanks again everyone here has been great with my other question even the dumb ones.
    ~John

    #29636

    Ryan
    Keymaster

    It doesn’t matter. The pins on the ramps are paired up. 12AB there really is not a polarity on a stepper, swapping any pair will reverse the movement direction, swapping both pairs is a double negative.

    #29641

    John
    Participant

    So I’ll just have to test out all the motors and their connections to make sure everything is rotating the right way. I had a feeling this was going to be the answer but I was hoping there might be an easier way.

    Thanks again for the help.

    Additional important question I have while looking at the Z assembling instruction I noticed the tool mount seemed to be flush with the bottom of the pipes. I couldn’t tell if that is correct. I bring this up since I noticed my universal mount from thingiverse wasn’t flush with the bottom. Is that an issue? And could it be compensated with by the universal tool mount attachment?

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.