Inaccurate travel dimensions (esp. Z)

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Inaccurate travel dimensions (esp. Z)

This topic contains 9 replies, has 4 voices, and was last updated by Profile photo of Ryan Ryan 2 weeks, 6 days ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #29965
    Profile photo of Michael Wafler
    Michael Wafler
    Participant

    Hi,
    Completed my first build and now looking for some help –
    1) Did you buy everything from here? No –
    a) 5 NEMA 17 stepper motors using RAMPS/ARDUINO combo flashed with “Marlin RC7 MPCNC w/LCD” downloaded from here. No LCD currently. Controlling via USB.
    2) No end stops
    3) PC

    So far I have been able to control the router manually with Estlcam, and send gcode for plotting. The dimensional accuracy of the product though is quite inaccurate. The X/Y direction seems to be doubled in size, while the biggest issue – the z axis is moving but very little. It moves quite freely/quickly when I manually control it via Estlcam so I don’t think binding is an issue. I can move it through its full range. E.g., For a 10mm Z movement in ESTLCAM, the z axis moves about 1 mm. I set it for a 5 mm depth cut and by the end of the gcode, its Z depth has only minimally changed despite the software stating its now 5mm deeper.

    Unfortunately I’ve been unable to connect with Repetier-host to test my set-up with different software. I’ve tried multiple baud rates, two different computers, and re-flashed the stack multiple times. I’m now getting a MAXTEMP error/Kill command which I can’t seem to solve.
    Thanks for any input!

    #29988
    Profile photo of Ryan
    Ryan
    Keymaster

    You can’t connect with repetier because it sounds like you flashed the estlcam firmware on it. If you didn’t get things here you should really list what you are using if you continue to have errors, and a picture because it sounds like you aren’t using the resistor on t0 either (max temp error)?

    Software

    That link above is how I recomend doing things, but you will need to get my marlin firmware back on your board.

    #30970
    Profile photo of Jim
    Jim
    Participant

    Have you found a solution to this yet? I’m having similar problems except all XYZ axes move a fraction of the instructed distance. I am, however, using a re-arm board with ramps and smoothieware. I’ve gone through the math for steps_per_mm and have my jumpers set correctly on ramps but can’t seem to figure out why it’s doing what it’s doing.

    This doesn’t seem to be firmware specific.

    • This reply was modified 3 weeks, 3 days ago by Profile photo of Jim Jim.
    #30984
    Profile photo of Ryan
    Ryan
    Keymaster

    It has to be your firmware Jim. Have you had a look at my smoothie settings? I have a basic file on the firmware page.

    #30991
    Profile photo of Neil
    Neil
    Participant

    I would suggest checking your jumpers as Ryan has posted here: https://www.vicious1.com/assembly/ramps-wiring/
    If all that looks good and you have flashed his RC7 FW: https://www.vicious1.com/marlin-firmware/

    Next step would be throw a pen on your tool holder. Using the LCD or Repetier move the axis a known amount.
    LCD – Prepare – Move Axis – 10mm – (X or Y) then measure with a caliper to see how far you are off.

    You can tweak it in the fw if it is only off by fractions of a mm and you really want to get it dead on
    LCD – Control – Motion – Steps Per MM (X and Y – 200 default).

    You may be using some goofy steppers which do not have step angle of 1.8° if that is the case find out what they are and use the reprap calc to get you some different values: http://www.prusaprinters.org/calculator/

    give us more info on your hardware pics help as well.
    Neil

    #30992
    Profile photo of Neil
    Neil
    Participant

    Sounds like your steppers are 0.9° step angle. Just my guess
    /edit or would that make it smaller.. eh I don’t know thinking out loud again… Get us some more info and we can help you through it.
    Neil

    • This reply was modified 3 weeks, 2 days ago by Profile photo of Neil Neil.
    #31134
    Profile photo of Jim
    Jim
    Participant

    Yes, I actually used your config and just modified travel specifications, pins for the re-arm, and gamma_steps_per_mm to match my M8 threaded rod and microstepping factor (tried both 1/32 and 1/16). I have Panucatt’s SD6128 drivers and set the VCC to .8V.

    I’m not sure if this applies to the re-arm board/ramps, too, but I’ve read that the smoothieboard can’t output the current needed to drive two steppers with a combined 2A+. I am thinking about trying to use my spare E1 and E2 spots to see if that makes a difference. I’m skeptical but also wondering if I change the setting from Cartesian to CoreXY if that’ll do anything.

    I’ll keep playing and keep you posted. If you have any other suggestions, I’d appreciate them as well.
    Thanks
    -Jim

    #31143
    Profile photo of Jim
    Jim
    Participant

    Okay, so I upped my pulse per microseconds to 2 and realized I was traveling exactly .25 the distance as I was directing the machine to do–leading me to multiply steps_per_mm by 4. I don’t quite understand why it works now with alpha and beta at 800 steps and gamma at 10240. I also upped the voltage on my drivers to 1. The only thing I have to figure out now is which of those changes is causing my drivers to get crazy hot. I’m going to start with decreasing the voltage though.

    #31144
    Profile photo of Jim
    Jim
    Participant

    I know this is my third time posting in a row lol but the only way I can get my physical travel to be equivalent to the distance I tell the machine to travel is 800 steps per mm for x and y and 20480 for z!! That has to be wrong.

    As far as the math goes, it’s supposed to be
    (steps_per_mm * micro-stepping factor / pitch * pulley teeth)
    but that doesn’t work for me. The only way I can make sense of it, is if it’s instead:

    (steps_per_mm * micro-stepping factor / (pulley teeth / pitch)) for X and Y.

    As far as Z goes, it’s supposed to be (steps_per_mm * micro-stepping factor / rod pitch) but again, the only way I can make this work is if

    (steps_per_mm * micro-stepping factor / (rod pitch / rod diameter ))
    What am I doing wrong here? Haha

    #31145
    Profile photo of Ryan
    Ryan
    Keymaster

    Jim this thread was all about ramps and marlin, you are not using either of those.

    It would be best if you gave us the details of what you are using. You are using smoothieware, on a brand new board, with a ramps shield, and some crazy drivers that go to 128th stepping. Whatever number it takes is what it takes. It seems like the machine works but you are seeing different numbers because your step rate is crazy high.

    But I can only guess because you have not given any of the important details.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.