Issues with z axis skipping or buzzing [Solved]

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Issues with z axis skipping or buzzing [Solved]

This topic contains 5 replies, has 4 voices, and was last updated by  Andre_L 5 months, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #21942

    Carl
    Participant

    I’m writing this to hopefully help someone that has or is having the same issues I did when starting this project.

    tl;dr
    It was the stepper motor.

    Backstory
    So I started this project about a year ago. I had just gotten a 3d printer and I vowed to myself that I would never print “trinkets” with it. Naturally, I would pick one of the biggest 3d printer project out at the time. The MPCNC.

    After printing it all out, which took a ton of time, I assembled it all with high hopes of cutting stuff as soon as I did a few runs with the pen and paper. Unfortunately, it didn’t go that way. After putting it together checking everything it would get this “buzzing” from my z axis stepper motor that sounded like it was jamming.

    I took out everything made sure it was strait, level, lubed, etc. Nothing seemed to work. I sent different gcode and that still didn’t work. I probably spent a good 3 weeks trying to debug this thing. It got the best of me. I put it in the corner of the garage with the intent of throwing it up on ebay when I got around to it.

    Fast forward ~10 months
    For some reason or another I went out in the garage and saw it sitting in the corner and thought I can’t let this stupid thing beat me. I mean, there are 10s of new videos a week going up on youtube of people building this thing. I’m going to get this working.

    So I started researching all of the potential issues that it could be. Since I had build it so long ago, I still had all of the -old- design. So I thought it had to be something with my printed middle parts that was throwing the whole thing out of alignment and causing this thing to jam up and the z stepper motor to skip. I found the the z nut lock was cracked and broken so I searched high and low to find it. Someone on this forum sent me a link to download it. (thanks Barry) So when I reprinted that and put it back on…. same issue. F.

    Next, I had some yellow PLA I wanted to get rid of (probably would have chosen some other color) so I started printing all of the new middle pieces. (BTW, the design of new middle is awesome.) This took a couple of days to get done, luckily I had the holiday to keep the printer running. Once I had all of the pieces assembled, I took it all apart and put on the new pieces…and same shit, it kept buzzing. W. T. Serious F. I was about to flip the table over. But the engineer in me, said “let’s get to work and debug this thing”.

    So looking at all of the other threads I tried everything under the sun to try and figure out what was going on. I knew that it would kind of work when the stepper motor was moving at a slower speed, so I tried tweaking that. I did get it to a point where it would “kind of” work but something was still clearly wrong. I reflashed the firmware with Ryan’s latest. Still nothing.

    Next, I re-took everything apart again, leveled, squared, tightened down everything.
    – I lubed up threaded rod with white lithium
    – Swapped out the stepper driver motor
    – Checked the cabling
    – Changed the power supply
    – Checked to make sure the threaded rod wasn’t bent (nope)
    – Re-did all of the belts…because i was grasping at straws here.
    – went back and forth between an aluminum coupler I have and the pineapple printed coupler

    At this point I was thinking about all of the parts that I still had on the machine from prior to printing the new parts. The only thing left was the stepper motor. In all fairness I did test this and it would spin, along with the fact that the likelihood of stepper motors actually failing is very low. I pulled it off to make sure I had all of the wires correct and I wasn’t using a 1/2 wound coil (these have 6 wires). It all looked good.

    So I had some other 3d printer project parts laying around so I took a motor from there. (this was a different brand and smaller than the 5 I had on the machine already) I put this one on the z axis. And…. holy shit it worked. It worked great actually. I did some speed testing with the motor when it was off of the machine but still hooked up and I could clearly see that it had issues with speed as it would buzz when sending a large travel distance. I’m guessing the specs for this motor can handle the higher demand from the z axis because the x and y work great.

    I ordered a slightly bigger motor that I just finished putting on and it works great. (Amazon prime baby!)

    Hindsight is 20/20 – but I hope this helps someone else in a similar situation as me save some time.

    #21947

    Ryan
    Keymaster

    Man, That should be made into a movie. Sorry for all the frustrations, and I am super stoked you got it going! I am pretty sure you are the first to actually have a stepper issue, that would definitely be my last thing to trouble shoot.

    Got me thinking I should put up a trouble shooting chart of some kind. Might take a while to get get it right but it sure would help a lot of people.

    #28339

    Andre_L
    Participant

    @vicious1, I support your idea of putting a troubleshooting chart together. I received all my parts from you on Monday and I assemble it. I was impress by the quality of the parts especially how tight they are. My conduit fits very tight so even with all the tension bolts all loose, the X and Y axis were rolling fine but almost too tight.
    Yesterday I went on with the first test drawing the crown to discover that the Z axis has problem. I cannot have the z axis go all the way on his whole course without jamming at some point.
    I seems to have a similar problem as Carl but since I am at day one of testing I don’t have the accumulated frustration that he had build. Carl I salute your perseverance.
    So my question, what would be the first test or check should I perform to solved this problem? could it be that the pineapple coupling is not screwed tight enough? Just don’t want to crack it.

    #28341

    Ryan
    Keymaster

    Move it all the way up and down by spinning the pineapple by hand. See if you notice any binding. Lube? How fast are you trying to move it, under 8.3mm/s? This axis should move very easily if not there is an assembly issue.

    #28342

    P3DCNC
    Participant

    I originally had trouble with this as well. My threaded rod was binding somewhere in the XYZ assembly.

    The first test you should do is to disconnect the motor from the pineapple and turn it by hand all the way. It should be unrestricted. If it’s binding at some point, note the distance it is in and have a look at that area.

    Originally I had the nut for the threaded rod at the top and the spacer at the bottom. I switched them around so the threaded rod nut is at the bottom, that solved it.

    Later on after some use it reoccurred but in a much milder way. So I added some grease to the rod. Problem resolved.

    Rock solid ever since.

    #28354

    Andre_L
    Participant

    Well, it’s incredible what a bit of oil can do! It seems to have solved the problem for now. So I can go to the intermediate instructions and see if I can go further. Very happy for now!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.