Marlin, Estlcam & Circles

New Home Forum Software Development Marlin, Estlcam & Circles

This topic contains 7 replies, has 3 voices, and was last updated by  Didier 1 year, 2 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #13047

    Franz Maier
    Participant

    I have the following problem:

    using the G02 Command in ESTLCAM for circles, they dont get circular, if they have a small diameter (~<3mm) Using multiple points the circles lokk ok. See image. I think, the GCODE looks ok, so I assume the Problem in Marlin transfering G02 to toolpath. Does anyone know this behaviour?

    #13062

    Ryan
    Keymaster

    When choosing circles are you choosing to cut inside the path, with a 3mm bit? While choosing on the path with the 3 points?

    You can chose inside outside and on the path.

    #13074

    Franz Maier
    Participant

    The circles are 2mm – 10mm bit is 0.9mm.
    For the attached immages I have chosen outside, on and inside the path, each with G02 and multiple points. Multiple points paths look ok but the four smallest circles with G02 are not circular.

    #14094

    Didier
    Participant

    Hi, I have the same problem, any idea people ??

    #14108

    Ryan
    Keymaster

    Try it with arcs turned off, That might be a firmware thing I have not looked into. Maybe I can run some tests later, not sure yet.

    #14176

    Didier
    Participant

    @vicious1 And second thanks of the day, it is perfect !!

    #14179

    Ryan
    Keymaster

    Sweet! Thanks for testing that out. I need to update the EstlCAM walk through now. So awesome, feels like the machine gets better everyday.

    #14214

    Didier
    Participant

    Also there is the v9 of Estlcam with 64 bit. Actually i’m testing laser engraving with estlcam, i’ll ask to the developper if he could add a parameter for M106 SXXX directly in the tool section because sometimes I need various powers for each toolpath (changing in general parameters or gcode is not a good solution actually).

    His software is not optimized for that but for milling, but why not now eheh 🙂

    With laser there is a little decay on the starts because actually the laser have no time to get is power before XY moves (i think it is a latency between the ramps and the jtech driver board, not sure). I’m trying to play with a slow Z speed and the just distance to let time to the laser to power on at time. It is a trick, not a solution. So a decay parameter before moving XY could be a good solution.

    And to answer to you, of course this machine get better thanks to you, soft developpers and the amazing community on the forum !! About that, I have an idea to share to evolve the machine for engraving, drawing or cutting big projects, i’ll create a post for that, you could tell me if you like that 🙂

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.