Maryland Build – Complete (sort of)

New Home Forum Mostly Printed CNC – MPCNC Your Builds – MPCNC Maryland Build – Complete (sort of)

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Dan Dan 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #30178
    Profile photo of Dan
    Dan
    Participant

    Well, we have an operational MPCNC with a pretty large 2’x3′ cut area! The project took about two weeks from the start of printing parts. Many thanks to Vicous1 for these awesome plans. Instead of a router I dropped in a 500 watt spindle; so much quieter and for $135 on Amazon it seemed worth it. I also used a TB6560 control board and am running Mach3, so a slight departure from the Ramps set up. Speeds are pretty good and crisp.

    There is always something new to do to improve a project and I’ll be moving on to an enclosure very soon. Then electronics box, lighting, cable chains…. I hope to have a YouTube video up tomorrow of the machine as it runs now.

    #30205
    Profile photo of Bryan
    Bryan
    Participant

    What kind of wiring did you use?

    #30211
    Profile photo of donc
    donc
    Participant

    Which brand of the TB6560 board did you use and did you have any problems setting it up? I am a Mach3 guy for a long time and would feel more comfortable with it over ramps.

    #30221
    Profile photo of Dan
    Dan
    Participant

    @ Bryan – Ummm, wiring; well, I didn’t use an Arduino set up. This is more of an old school set up using Windows based stuff. The Toshiba board is really only designed to run three motors but I’ve doubled up the x and y on one driver each. (NOTE: This was a duh, moment on my part – since the motors are on opposite sides of the CNC you need to flip the wiring so they go in opposite directions. I couldn’t figure out why the steppers were fighting each other…yeah, brilliant.) Since the NEMA 17s are pretty low draw, especially at 25% current it seems to be working fine.

    @ donc – Yeah, I haven’t played around with Ramps yet and am also pretty comfortable with Mach and old Windows laptops. This TB6560 was bought several years ago in a kit with three NEMA 23s. It was just an eBay purchase from Longs Motors I think. I know they’ve changed these boards around a little bit and some people have had trouble with them. This particular one has been pretty tough; it’s been shorted out (rather spectacularly I might add with lots of blue light), dropped, bent, covered in dust, etc. and it just keeps on working. I should have bought several of them.

    Here’s a video of the CNC in operation from this morning. https://www.youtube.com/edit?o=U&video_id=jZNNK5Rsdzw

    Dan

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.