Motors only turn one direction.

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Motors only turn one direction.

This topic contains 4 replies, has 2 voices, and was last updated by  Ryan 1 year, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #13867

    rogo
    Participant

    Hello,

    I’ve got everything plugged in and working. In repetier, I can tell the motors to move on the + side (so I can move them +100mm, everything moves in positive direction), but whenever I tell the motors to move in the opposite direction, nothing will happen. How do I fix this? I’m on a mac if that helps.

    Thanks!

    #13870

    Ryan
    Keymaster

    My hardware or yours?
    My firmware or other?
    End stops?

    That behavior happens when it thinks an end stop is triggered.

    #13892

    rogo
    Participant

    Thanks for the response. It’s your hardware from your kit…. the firmware was installed via the “mac” help from this forum. I have no endstops installed… however it does in fact appear to refuse to reverse do to “< 9:11:24 AM: echo:endstops hit: Z:1.00”. Is this something that can be changed in repetier host?

    #13900

    rogo
    Participant

    Yeah just to add on… I’ve been trying to poke around in the Marlin firmware but can’t get anything to make a difference. For x,y, and z, can only move in positive direction….

    #13906

    Ryan
    Keymaster

    It does not make sense. My firmware is preset. If you didn’t add endstops you should be fine. If you bought it from me no firmware needed to be installed. Whatever you installed should be from this link, https://www.vicious1.com/marlin-firmware/ you would only need to change the baud rate for a MAC. (no idea why a mac doesnt work on a higher buad rate).

    There are only two setting you need to worry about that deal with endstops, – #define min_software_endstops false (needed to machine in the negative direction), and the true false endstop settings for NO and NC…

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.