Moves between cuts are incredibly slow. G-code Attached.

New Home Forum don’t use this one, I need to sort and delete -Troubleshooting Moves between cuts are incredibly slow. G-code Attached.

This topic contains 6 replies, has 2 voices, and was last updated by Profile photo of Benjamin Shaw Benjamin Shaw 6 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #17703
    Profile photo of Benjamin Shaw
    Benjamin Shaw
    Participant

    I’ve attached a simple G-code program that cuts a 14″ square 1″ deep in two passes with some tabs.

    Every movement that is not a cut goes very slow. I’ve tried every setting I can think of to speed it up.

    I’m using Fusion 360. Cutting Foam. Any thoughts would be greatly appreciated.

    Here are my settings in Fusion:

    1

    Attachments:
    1. Square.zip
    #17706
    Profile photo of Jason
    Jason
    Participant

    Your surface speed maybe? It is set to 23mm/s. (654 feet per min)

    I am not familiar at all with 360 but that one stuck out to me.

    #17707
    Profile photo of Benjamin Shaw
    Benjamin Shaw
    Participant

    Unfortunately, I think the surface speed is referring to the speed of the tool rotating. It’s directly tied to the spindle speed, both of which are irrelevant since I have no speed controls other than manual. :/

    1

    #17710
    Profile photo of Benjamin Shaw
    Benjamin Shaw
    Participant

    I should also add that if I simulate the cuts in Fusion 360, the cutter moves quickly in between cuts. Does this indicate an issue with Repetier settings?

    #17717
    Profile photo of Jason
    Jason
    Participant

    If you look in your gcode for the feedrate change that should show whats wrong.

    #17718
    Profile photo of Benjamin Shaw
    Benjamin Shaw
    Participant

    Digging into that now. I’m seeing that it is set to F2000.

    Also, I’m guessing this value is coming from the custom post processor I am using to get the code out of Fusion. Looking at the code, it has the following section in it that I think sets the feed rate:

    1

    Also, Here is a screenshot of the resulting G-code:

    2

    #17814
    Profile photo of Benjamin Shaw
    Benjamin Shaw
    Participant

    Wondering if the command that sets “Use G0” moves to false could be causing my issues with slow movements. I have zero G0 rapid commands in my post processed code.

    1

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.