MPCNC Stepper Motors

New Home Forum Mostly Printed CNC – MPCNC Advice – MPCNC MPCNC Stepper Motors

This topic contains 17 replies, has 7 voices, and was last updated by  Douglas Bell 6 days, 8 hours ago.

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #42903

    Douglas Bell
    Participant

    Hi All

    This is my first venture into CNC routing,  I was going to build at first an OZ machine from OpenBuilds but the cost was way to prohibitive for my first CNC machine so I was looking around for alternatives and I came across this website.

    Everything appealed to me, I have a 3D printer and I have all the 25mm Steel conduit I need. The parts list required is quite small for purchase and not that expensive.

    My first question is on Stepper Motors, there are lots of variations on Nema 17 stepper motors so was unsure about the specifics and was wonder if the following Steppers will do.

    https://www.amazon.co.uk/Quimat-Stepper-Connector-Mounting-Bracket/dp/B06XQWMDWT/ref=pd_cart_vw_2_8?_encoding=UTF8&pd_rd_i=B06XQWMDWT&pd_rd_r=RZ0NY9B47J1V1QEV82PR&pd_rd_w=Aacwp&pd_rd_wg=ugBRh&psc=1&refRID=RZ0NY9B47J1V1QEV82PR

    Cheers

    Druid

    #42904

    Ryan
    Keymaster

    Yup, make sure you use the drv8825 drivers as those things are 84/ozin

    1 user thanked author for this post.
    #42905

    Douglas Bell
    Participant

    Hi Ryan

    Thanks for your reply, yeah I already have the drv8825 drivers in my Amazon Cart.

    Cheers

    Druid

    #43017

    Bryan
    Participant

    I have similar strength steppers.  They are very strong for how small they are.  You can lean on the gantry and it will push you over before they skip steps.

    #43118

    Douglas Bell
    Participant

    Hi All

    Got all my electronics and been printing the parts for the last couple of days, this is going to take a while.

    Instead of creating a new thread hope its ok to use this one for other advice.

    Looking at both my Mega and Ramps board I see none have an SD card slot, but I have seen lots of members talking about uploading gcode with SD Card, how do I upload a program without the SD Card, is it done directly via USB from a PC?

    Cheers

    Druid

    • This reply was modified 2 weeks, 2 days ago by  Douglas Bell.
    #43121
    Hi All Got all my electronics and been printing the parts for the last couple of days, this is going to take a while. Instead of creating a new thread hope its ok to use this one for other advice. Looking at both my Mega and Ramps board I see none have an SD card slot, but I have seen lots of members talking about uploading gcode with SD Card, how do I upload a program without the SD Card, is it done directly via USB from a PC? Cheers Druid

    U need to use smart controler screen he have sdcard slot

    https://shop.vicious1.com/collections/parts/products/full-graphic-smart-controller-big

    #43158

    Douglas Bell
    Participant

    Hi

    thanks for the reply, I must have missed the part that said the screen and SD Card was a requirement for the build. I will have to see if I can purchase one quickly in the uk.

    cheers

    Druid

    #43160

    Ryan
    Keymaster

    It is not a requirement.

    Software

    You can use USB as well.

    #43582

    Douglas Bell
    Participant

    Hi All

    Got all my parts printed, gantry build and I am just going through the electronics and stuff and noticed that my pulleys are 2oT instead of 16T, how much of an issue will this cause or can I change a parameter in the software to fix this?

    Cheers

    Druid

    #43586

    Douglas Bell
    Participant

    Hi Ryan

    Because of the quality of my 3D printer (cheap Chinese Prusa knockoff) I am finding I just can’t get my gantry square and there is maybe a difference in 5mm – 10mm on each side on the x and y axis, now I can fix this by turning the stepper motors until I have each side the same distance from the corner blocks, now this hasn’t been tested yet to see if they will stay square, however your auto squaring would be perfect for me, I haven’t yet uploaded any firmware onto my mega and ramps yet and was hoping maybe to use your auto squaring firmware, how useable is your firmware for this, is there any issues you have come across?

    cheers

    Druid

    #43594

    Ryan
    Keymaster
    Hi All Got all my parts printed, gantry build and I am just going through the electronics and stuff and noticed that my pulleys are 2oT instead of 16T, how much of an issue will this cause or can I change a parameter in the software to fix this? Cheers Druid

    You will just need to reduce the X and Y axis steps in the firmware. No big deal.

     

    Because of the quality of my 3D printer (cheap Chinese Prusa knockoff) I am finding I just can’t get my gantry square and there is maybe a difference in 5mm – 10mm on each side on the x and y axis, now I can fix this by turning the stepper motors until I have each side the same distance from the corner blocks, now this hasn’t been tested yet to see if they will stay square, however your auto squaring would be perfect for me, I haven’t yet uploaded any firmware onto my mega and ramps yet and was hoping maybe to use your auto squaring firmware, how useable is your firmware for this, is there any issues you have come across?

    I have a blurb about this in the FAQ’s. You might just need to use it for a little while to break it in and then do a quick rebuild.

    The Dual Dual firmware is pretty solid, we have a new one about to be released hopefully tonight that works out a few of the minor kinks. I do not recommend it though, at least not yet. This is also in the FAQ’s; end stops add another layer of difficulty, and should only be used when you are comfortable with the machine and the CAM first.

     

    #43642

    Douglas Bell
    Participant

    Arrrrrrg, I have just fried my Ramps board while trying to set the voltage on one of my Stepper Drivers, accidently touch 2 pins with my meter probe on the Stepper driver.

    Well I think its my Ramps board that is fried.

    If I unplug the 12v power supply and plug in via USB everything powers up and I get to the menu settings on my LCD, unplug the USB plug the 12V supply into the Ramps board, LCD lights up but menu never loads. So I can only assume something has fried on the Ramps board. (I have taken the driver board that I caused the issue with and replaced it in case it was this that was faulty)

    Druid

    #43644

    Jeffeb3
    Participant

    It’s the 5V regulator on the mega. It converts the 12V to 5V for the electronics.

    #43682

    Barry
    Participant

    Looks like one of these by the power plug on the arduino board.

    IMG_20170911_222520

    1 user thanked author for this post.
    #43746

    Douglas Bell
    Participant

    Hi

    Thanks for the replies, yeah I checked the regulator and its not giving me 5v out, it was quicker for me to buy a new Mega than to get the regulators so just went for that, I will eventually fix the mega and use it for another project, good news the Ramp and Drivers are good.

    I have everything built and wired up, X and Y work great, unfortunately my Z axis is struggling due to my £100 3D printer tolerances on its print, I have found that the support below the Stepper coupler with the bearing is out by about 1.5mm, because of this the screw jams in the bearing and the Z axis will not move, as a test I removed the bearing and the Z works perfectly.

    Can I leave the bearing out or should I modify and print a new support mount with the bearing in the correct place for my tolerances?

    Cheers

    Druid

    @Ryan, I have to congratulate you for a system that even with a cheap and nasty printer can be printed out and successfully built with someone with limited knowledge or experience, I know building the machine is only the beginning of the journey but for 2 weeks of work I have a machine that moves in the X,Y,Z axis, now to see how it plots via a pen.

    #43750

    Mike
    Participant

    I don’t think it would be advisable to leave the bearing out, as that might allow some play in the Z axis. Somebody else had a very similar problem awhile back in this post.

    https://www.vicious1.com/forum/topic/z-axis-issue/

    Solution there was new print of the parts.

    #43754

    Ryan
    Keymaster

    Sounds like your center gantry might be misaligned and the z axis is not truly vertical?

    #43756

    Douglas Bell
    Participant

    Its defiantly misaligned, more to do with the prints not being exactly on tolerance to be honest.

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.