Need help getting a Max Z endstop to work

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Need help getting a Max Z endstop to work

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of Tom Cole Tom Cole 6 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #24549
    Profile photo of Tom Cole
    Tom Cole
    Participant

    I can get an end stops to work and home x,y and z as minimums, but I can’t get it to call Z max home, which is what I want for z. I did un-comment a line to make Z max active and I can get marlin to report back that it is “triggered” when closed, so I know I have it wired to the correct pins, but try as I might, I can’t get Repetier to home Z at max. I wire it up and set everything in Repetier as I think it should be and when I press “Home Z” it starts going down, not up.

    I have since re-flashed Vicious 1’s new/fixed RC8 fresh so all settings are stock.

    Beginning with that fresh version, what do I need to un-comment/alter in the firmware to get this to work, and what settings do I need to set in Repetier.

    Any tips are appreciated.

    And any ideas for mounting the endstop for Z max would be great.

    #24551
    Profile photo of Ryan
    Ryan
    Keymaster

    RC8 does not work, not even the bug fix. I Thought I took all the links down for it. sorry.

    I have not done it this way but in the firmware I think you need to active the max endstops, make sure they are wired correctly, set your z height correctly and tell it to home to max.

    I don’t use them so that is as much help as I can give you.

    #24572
    Profile photo of Martin DB
    Martin DB
    Participant

    What’s the problem with rc8? I’m using it with laser, milling and vinyl cutting without issues.

    #24573
    Profile photo of Ryan
    Ryan
    Keymaster

    The combination of the lcd and the giant number of z steps will cause random failures. The bug fix branch works but then the LCD menus fail.

    It is a random problem. be-careful when milling, other non z axis activities are fine, cutting, lasing.

    #24599
    Profile photo of Tom Cole
    Tom Cole
    Participant

    I downloaded and installed it as soon as you posted and never checked again. I’ll go back to previous firmware and see if that works.

    FYI, I ran a milling program that drilled 480 holes 25mm apart to make a 500×500 grid. The holes were 10mm deep and I pecked at 2mm per z step and it did not fail. Granted that’s not contour milling so the z steps were not severely numerous.

    I’m glad it didn’t fail because that was my first Tom’s brain to Fusion 360 drawing to Estlcam to Repetier to MPCNC project. I had a beer to celebrate linking all the steps! I’m used to watching Haas VMC’s cut aluminum and comparatively, this was like watching grass grow. But I have seldom been so satisfied.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.