Repetier Error (line number) while try to engrave

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Repetier Error (line number) while try to engrave

This topic contains 11 replies, has 4 voices, and was last updated by  Stuart Smith 3 months, 3 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #27892

    Stuart Smith
    Participant

    I am getting “error: Line number is not last line number +1. See attached

    #27897

    Stuart Smith
    Participant

    Here’s what i’m trying to engrave. It’s not a complicated piece all the same depth.It goes through Estlcam as a dxf file and saves fine as CNC file. It’s not consistent where is stops either. Very frustrating.

    Attachments:
    #27900

    Stuart Smith
    Participant

    DXF file

    #27909

    Ryan
    Keymaster

    try using repetier host not server, and rename your file to .gcode.

    #27916

    Stuart Smith
    Participant

    Host does not work on my work laptop for some reason. I did dig up one of your older post via google search about the same thing. So I downloaded the Estlcam version 10 beta and it works now. I knew the server had potential because I was able to do everything else. Something else that seemed wierd in Estlcam after you save you can play the file and watch the path its going to take. If I didn’t play the whole thing all the way through before I hit okay I think that’s all that transfers to platform. I passed the DFX through Estlcam 3 times and each time it was shorter viewed before I clicked okay. And I believe that it failed right where I stopped the playback in Estlcam by clicking the okay button. Does that make sense to you? Do I need to let it playback every time I pass a new file through Estlcam?

    My first Engraving turned out really good.I wanted to put it on a piece of walnut but the piece I have was too small. See attached.

    #27919

    Barry
    Participant

    Make sure you disable/uninstall the repetier server processes or host won’t work.

    #28002

    Stuart Smith
    Participant

    Maybe that’s why it wouldn’t work for me last weekend. I spent hours messing with it.

    I also forgot to mention a setting in setup or program in Estlcam. File Ext was changed before to Gcode. But I left it on cn instead this time. So it has to be Gcode for sure Vicious? It went all the way through without fail.
    It is not my intention to frustrate you guys with a lot of questions. In my field there are several different ways to setup my equipment. It’s just a matter of which algorithm you chose to run with.

    #28012

    Ryan
    Keymaster

    No I am not sure I don’t use server, I just remember hearing that at one point. Sorry, second hand hearsay.

    #28020

    Bill
    Participant

    You can use .nc or .gcode and probably most anything else. You just have to configure Repetier-Host to know about the file extension. They all contain the same content.

    1 user thanked author for this post.
    #39111

    Stuart Smith
    Participant

    Has anyone had any luck pinpointing this issue? I stepped away from my MPCNC to work on some other projects and I have done a clean wipe and reloaded the latest software Estlcam and Repitier host (not server) and I get this same error still. Very frustrating. Please advise if anyone has a clue.

    #39112

    Barry
    Participant

    Everything I can find says it’s a connection issue. Either the baud settings are wrong, or something is trying to access the port.

    #39145

    Stuart Smith
    Participant

    Hey Barry thanks for getting back to me. I went ahead and got Fusion 360 working and pushed it through Repitier. I just started using it a couple of months ago and noticed that some of you guys are using it for the MPCNC. Very nice CNC in 360 program I must say. I didn’t have any connection issues with 360 to Repitier today. Some Old Guy has some good footage on the setup so it wasn’t too painful. Still have a few hairs left. Thanks again.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.