Sketchup DXF to ESTLCam

New Home Forum Mostly Printed CNC – MPCNC Advice – MPCNC Sketchup DXF to ESTLCam

Tagged: 

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of Ryan Ryan 4 weeks, 1 day ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #36475
    Profile photo of Peter A Mills
    Peter A Mills
    Participant

    I’ve been drawing in Sketchup and exporting as a DXF to ESTLCam. I know it’s probably not the most efficient way but I know my way around Sketchup enough that I can make what I want pretty easy. The problem I’m having is that the size in Sketchup (drawn in MM) doesn’t import into ESTLCam at the same size. I found that I need to scale it by 91.75% to get it to match up with my grid in ESTLCam. My grid is set at 25.4 x 25.4 so I can look at things in inches. Does anyone know why that might be? It was through trial and error that I figured that out.

    SK1

    ES1

    Attachments:
    #36494
    Profile photo of Ryan
    Ryan
    Keymaster

    The workflow you have is great, sketchup to dxf to estcam is how we all do it we all just use different programs (solidworks, fusion, illustrator, etc).

    I have not used sketchup in years but you need to find its DXF settings, to make sure it is exported in mm. Any Program you use to design lets you work in any system or units you want and DXF’s can be exported in any units. Sounds like yours might be exporting in pixels. From what I can see you might either have the wrong version selected in the first drop down of you do not have “one to one” selected.

    The other option is when importing it to estlcam select a different units option, if you don;t see this go into settings and turn on “always ask” for import units. either way you can get them to match.

    I hope this makes sense, it doesn’t sound very clear when I reread it. Let me know or zip and attach your dxf if it isn’t clear and I can figure it out.

    #36532
    Profile photo of Peter A Mills
    Peter A Mills
    Participant

    Yeah, it makes sense. I just can’t figure out why it won’t import at the right size. It’s not really a big deal for 1 drawing, but wil lget annoying if I can’t figure it out. I’ve linked to the DXF and attached a screenshot of the export options. The forum wouldn’t allow me to upload the DXF directly. It seems to be exporting at full size but importing slightly oversize.

    https://www.dropbox.com/s/kkb013t5r9gfcv9/Growth%20Chart%20Ruler%20V2.dxf?dl=0

    Capture-1

    I had it set to import DXF in MM to ESTLCam. I set it to ask instead with the same result.

    Thanks.

    Attachments:
    #36536
    Profile photo of Ryan
    Ryan
    Keymaster

    What are your options in that drop down, release 14 is probably not the right one, which ones allow for the 1:1 checkbox to function?

    #36537
    Profile photo of Peter A Mills
    Peter A Mills
    Participant

    Interestingly, none of the file versions allow that checkbox to function.

    I got it though. I thought it was straightforward so I didn’t bother looking up how to export. Turns out I missed step 1 and that made the difference!

    From their support page: https://help.sketchup.com/en/article/3000165

    1. To maintain your model’s scale in the exported file, in SketchUp Pro, select Camera > Parallel Projection. Then set your view to one of SketchUp’s standard views by selecting Camera > Standard Views and selecting an option from the submenu that appears. (See Viewing a Model for details about the model view options.)

    #36538
    Profile photo of Ryan
    Ryan
    Keymaster

    Hmm, problem solved, in a way I never would have guessed. Glad you have it figured out.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.