Squareness issue???

Tagged: 

This topic contains 10 replies, has 6 voices, and was last updated by  SQLException 2 months, 2 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #44739

    Bernhard
    Participant

    Dear MPCNC community,

    1) Did you buy everything from here?
    No, not bought from your shop, but used recommended parts. Latest firmware acc. your homepage, but with M8 threaded rod at z-axis

    2) Are you using end stops?
    already disconnected, anyhow got interferences with them.

    3) Mac or PC?

    PC/Win-7

    1/32 stepping, steppers parallel

    Gcode with estlcam, run with SD-card at lcd-display

    after finishing my MPCNC and doing some cuts I´ve decided to make a spoil board with some holes to clamp material on it.

    ·         So I created a hole pattern in AutoCAD and gcode with Estlcam (Drilling Operation)

    ·         put my dedicated spoil board on the table

    ·         aligned it with the machine by positioning it to the x-axis (touching the spindle at x-min and x-max edge of the spoil board)

    ·         putting the spindle at x&y-min and started the drilling job

    20170925_201443

    So far so good, but then I realized that the hole pattern seems to be off (not parallel to x-axis). The edge distance of the holes varied quite a lot. I did another drill job with same input hole pattern, bigger drill bit dia. and smaller hole depth (pockets for countersunk screws). The machine hit the already drilled holes perfectly so I am pretty sure I haven’t lost steps in the first round.

    As a quick check, I´ve moved the spindle (with drill bit) to the first hole (x-min) and aligned drill bit and hole. Then pushing the gantry by hand (only x-axis) to the hole at x-max position and found out that this hole is off about 5mm in y+ direction.

    Therefor I am curious that this is an out of squareness issue cause the manual movement seems to be correct.

     

    Anything I am missing here? Looking forward to your help!

    #44743

    Darrell
    Participant

    You have to make sure the machine is square, you will find that the x and y tubes can rock back and forth unsquare when the motors are not engaged.

    First thing you should always do it make sure they are square by measuring down the x and y tube to make sure they are the same length from the their respective side tube.

     

    Then engage the motors so they stay square while you move it into position.

    #44750

    Ryan
    Keymaster

    I do it by measuring from a roller to the nearest Corner block and make sure it matches the other side.

    #44793

    Bernhard
    Participant

    Thanks for your help.

    Understood, this means everytime I move it by hand I need to recheck if I pushed it out of squareness. Which happens quite easy, cause my x-axis is about 1,2 meters long.

    Am I right, that the motors are not engaged when I connect power, I need to move the single axis before the block further movement by hand. So my procedure would be:

    1. Move to approximate start point by hand
    2. Check squareness, if out of square
    3. connect power, move axis to engage motors
    4. push motors by hand to get it square
    5. move via lcd to start point
    6. disconnect power to zero axis
    7. connect power and start machining from sd card

    Is it possible to change marlin that motors are engaged from the beginning?

    Shouldn´t the point “set home offsets” (underneath “prepare” in lcd menu) zero my machine via lcd?

     

    Thanks for your patience seems I havn´t got the big picture.

    #44807

    Ryan
    Keymaster

    You should easily be able to move it into square by hand without engaging the Steppers. Meaning it is only out of square because you pulled it around. If you can’t get it to hold square on it’s own, that means your center assembly probably needs to be rebuilt as it is out of square.

    The smaller the build the less this is seen, as you have built a very large machine it will be both easier to make not square (longer lever arms) and also easy to get a better square (more accurate measurements at the end of a long lever arm).

    #44821

    Jeffeb3
    Participant

    The procedure should be more like:

    1) Move it to the 0,0,0 by hand.
    2) Make sure the x and y axes are square, moving as necessary
    3) Power on machine
    4) Print from SD.

    That’s not the only way to do it, but it’s definitely an easy way.

    Shouldn´t the point “set home offsets” (underneath “prepare” in lcd menu) zero my machine via lcd?

    Yes, and AFAIK, it’s the same as sending G92 X0 Y0 Z0 (which you can add to your gcode, just don’t forget it’s there). That might be nice for an odd setup, like making a bunch of coasters, where after you cut one out, you moved with the LCD to (100,0) and started the gcode again.

    #44823

    SQLException
    Participant
    I do it by measuring from a roller to the nearest Corner block and make sure it matches the other side.

    Just to clarify: there’s imho two things to square (or align). First, the conduit has to be squared, second, the moving inner part (gantry or whatever) should be aligned right. That’s what Ryan described I guess.

    After that, I usually draw a circle (in wood) and check that it’s A.) perfectly round and B.) the right diameter. This should be sufficient to make sure the machine works correctly and accurate.

    But actually this doesn’t help with missing steps (if you have any, which you might not be aware of by now).

    Also I would not worry the “spoiled spoil board”. My own is misaligned (drill holes) as hell. But I don’t tend to align my workpieces with my spoil board anyway so…

    Btw: got the exact same Kärcher. High five!

    #44826

    Ryan
    Keymaster

    Missing steps is extremely rare and should be very obvious when it happens, either you should hear it or see it, a step missed will not be a 32nd step it will be a full step.

    When I try and help with things like this I do have to make some assumptions about what is happening, I am wrong a lot but If I just keep asking questions without giving suggestions people tend to get frustrated.

    #44828

    SQLException
    Participant

    Because I did not finish my wiring yet…

    (Reminder: https://i.imgur.com/lF48mSw.jpg)

    … I recently had a wire (one of the four stepper-wires) pulled into one of the bearings of a Roller. So the wire got flatten between the Belt and the bearing, resulting in “missing” steps (kinda).

    Everytime I heard something wrong in moving I checked everything… and because the gantry moved back already (so the wire is free again), it took rather long to understand whats happening.

    Long story short, there’s quite alot self made problems one can create :).

    #44941

    Just secure cables. Not securing theme is okey when you just make test if everything is moving like it should. Not securing theme when you leave machine to do some work is very bad idea.

    #44949

    SQLException
    Participant

    Exactly, that’s basically the outcome of my story.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.