Stepper which doesn't

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Mmmfishtacos Mmmfishtacos 1 month, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29296
    Profile photo of Bill
    Bill
    Participant

    So, I haven’t been printing much (just a couple of temperature towers) this weekend, though I did get a couple of other projects done. I went to start on a 6.5 hour print last night that I had to abort just a few minutes in, because the Y stepper connection to the RAMPS vibrated loose (second time now). This morning I reconnected it (also bent the pins slightly to give a bit more grip) and started again. This time I aborted it in a few minutes because the leveling screws loosened (I probably ought to be looking at alternative infill patterns). I took a trip to my favorite home products store and got a tube of blue Loctite, brought it back and reinstalled the leveling screws and reconfigured to have my Z home with a level bed. I had company coming for dinner so I thought I’d fire it up to show it off. It moved around just fine but wasn’t extruding. I manually pushed some filament through and it felt just fine so I tried just running the extruder for 10mm or so. No filament. I double checked the connection on the RAMPS an it was fine. I pulled the extruder apart far enough to see the stepper shaft and it only rocked back and forth when trying to extrude. I pulled it farther apart and tried to move the stepper with nothing attached. Same thing, it only rocks back and forth. So … I swapped the stepper out for a new one. Same symptom! (At this point I was mumbling to the effect of darn, shoot, heck, etc.)

    So my next step is to tear the wiring harness down and test the cabling. Has anyone got other suggestions?

    I’m also going to look at redoing the leveling screws to tighten up the bed to minimize the rattle, maybe bushings instead of linear bearings under the bed, though mostly it should clear up if I slightly resize the holes and switch from 3mm to 6-32 screws. I find the thumbwheels under the bed are hard enough to reach that I adjust by holding them and turning the screws at top. Since the 6-32s are an interference fit in the aluminum heater bed I switched to 3mm early on, but they are obviously too loose to keep everything in place.

    • This topic was modified 1 month, 2 weeks ago by Profile photo of Bill Bill.
    #29298
    Profile photo of vicious1
    vicious1
    Keymaster

    For the extruder that is a symptom of a disconnected wire. If everything checks out swap the extruder driver with another axis.

    On the bed leveling, I use m3, or 6-32 and lock nuts. The bed literally only needs to be leveled one time, I have never releveled a bed without a full machine rebuild. I see lots of thumbs screws and wing nuts all kinds of leveling gadgets, they all seem to move eventually. You only need to level one time so a screw and lock nut might not be the fastest solution but mine never move. Don’t get this confused with the x axis, that gets out of whack all the time if your are feeding filament too fast or get a clog and have to take of the nozzle, but the bed should never move.

    What is the rattle? The machine should be very quiet and smooth. Rattle is all bad, maybe a bad bearing, try rotating the smooth rod.

    #29372
    Profile photo of Bill
    Bill
    Participant

    Yup, one of the wires had come loose from the crimp in the harness. No wonder I soldered all the rest of them. This was the first stepper to get wired into the harness. I replaced the wires with soldered connections and she’s buzzing away.

    I haven’t figured out what the rattle is, it is pretty obvious but tough to trace. It seems to be worse on a Y move, but I can’t feel much vibration if I lightly touch the bed while it’s being noisy. I tried rotating each of the rods by 1/4 turn and it didn’t make any noticeable difference. My working theory is either the linear bearings under the bed or the connections between the heater and bed. I suppose it might be something about acceleration or deceleration, but I haven’t tweaked anything there from the original settings.

    #29414
    Profile photo of Mmmfishtacos
    Mmmfishtacos
    Participant

    hey bill,

    Try downloading the prusa edition of slicer. I keep repeating this but I can’t stress it enough about how it’s “changed” the machine. I had simular issues with noise that you did. And it has quieted down quite a bit, as long as I’m not printing something with a voronoi pattern ( lot’s of z hop) the machine is pretty quiet. It sit’s on my desk and I no longer have issues with it running while i’m trying to concentrate. When I slice with the old slicer or Cura it get’s loud again.

    I guess I should also mention that I export the gcode to repetier host and run it off usb, I haven’t tried running of the SD card in a while.

    Drivers

    Let me know what you think. It’s in the drivers package. You’ll get a model of a cool spitfire too, so that’s a plus!

    Also remove the auto bed level code.

    • This reply was modified 1 month, 1 week ago by Profile photo of Mmmfishtacos Mmmfishtacos.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.