Tool changes

This topic contains 3 replies, has 4 voices, and was last updated by  Jeffeb3 2 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #36573

    Dan
    Participant

    How does everyone change tools and realign their machine for multi tool operations? Do I need to get ends stops/ touch plates?

    #36574

    Barry
    Participant

    I’ve posted a video on YouTube on how I do it. End stops may cause issues if not wired correctly, so be careful.

    #37438

    Peter A Mills
    Participant

    I’ll add my question/problem here instead of adding a new topic. I’m also having some mixed success with tool changes. I’ve set it to go back to zero with this script:

    G00 X0 Y0 Z0

    M00
    ;Change tool: <n>

    It goes back to zero and then waits. There’s two problems with this. First, it goes in a straight line, so depending on how carefully I setup the piece and how level everything is, it sometimes drags across the piece and creates a cut where I don’t want one. This was especially pronounced in some barn wood that I used that was majorly warped and cupped. I need a way to keep the bit high and then drop down to zero.

    For this problem I’m going to try adding: G00 X0 Y0 Z5 as the first line. I’m not too proficient in Gcode but I’m hoping it’ll go to Z=5mm first then move down to zero.

    The second problem is that it won’t release the motors for a minute after it stops. This is just annoying. Is there any way around it? I’ve tried a few commands and haven’t found the right one.

    #37525

    Jeffeb3
    Participant

    G00 Z5 F300 ; Go to clearance plane, 5mm
    G00 X0 Y0 F1200; Go to XY 0 at 20mm/s, but stay at the clearance plane
    G00 Z0 F300; Go to Z0 at 5mm/s

    That should get you there, cleared of obstacles, assuming nothing is higher than 5mm

    Once you’re there, you can release the motors with M18. They will re-enable themselves when you move, so I don’t think you need the M17.
    http://reprap.org/wiki/G-code

    Some problems I can see coming:
    1) If you cleared out material at 0,0,0, then you won’t have a reference surface anymore.
    2) If you zeroed the first bit somewhere in the middle of the work (which can help for very wild surfaces to average out the terrible) then you need to zero out the next bit at the same place.
    3) If you release the motors, then they can change their squareness. If you didn’t do anything to make sure the machine was square when you started (ovals and words don’t really need to be square), then the next layer might end up with a different squareness. That can change of one of the x motors moves and the other doesn’t, for instance.
    4) If you release the motors, any reference of 0,0,0 for the steppers will be gone. When they turn back on, they will assume wherever you put them is 0,0,0.

    If you’re aware of these issues, I think you can easily find ways to mitigate them, or work with them. You might try to do some tests with some foam or large boards. To save time, you can just make some holes, and chamfer the edges, but put the holes a long way away from each other.

    Also, don’t forget you can cut gcode files into different files, and run them separately. If you make one for the 1/4″ bit and another for the chamfer, it’s very similar to running them in the same file with an M6 in the middle. But you can do whatever you want in between.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.