V9, V10, Martin's Fusion 360 Post Processor

New Home Forum Software Development V9, V10, Martin's Fusion 360 Post Processor

This topic contains 10 replies, has 2 voices, and was last updated by Profile photo of Martin DB Martin DB 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #29687
    Profile photo of P3DCNC
    P3DCNC
    Participant

    I’ve been comparing V10 and Martin’s post processors.

    V10 is very choppy. The issues I was having with jerky movements and slow corners (including text) comes from the V10 post processor. Martin’s works like a charm in this respect. The jerky movements go away and the tool path becomes smooth. FYI.

    Martin’s post processor, however, ignores the plunge speeds you set for the bits. It uses the Z travel speed of 300 which is too fast for plunging which is set at the bottom of the Post Processor Properties. I ruined plenty of test pieces until I figured out that all my G1 Z moves were at F300, sometimes F500 (not sure where that one’s coming from). Once I figured out that the post processor was the cause, I was able to set it to something more reasonable. Especially as I am working with aluminum at the moment.

    @martindb, any chance you can update the post processor to take the bit plunge settings instead?

    #29688
    Profile photo of P3DCNC
    P3DCNC
    Participant

    Update – Martin’s post processor, Z travel speed I’ve changed from F300 to F84. However, when it goes to plunge it approaches slowly, then lunges to penetrate the work piece (F500). How do I get rid of that ? I don’t mind the Z travel being higher, I wan’t the plunge to be much slower.

    #29696
    Profile photo of Martin DB
    Martin DB
    Participant

    Sure. Please post your original gcode file (I mean without manual editing) and the screen shots of the feedrates in the toolpath and post processor properties please.

    I’m using this posts processor without issues.

    #29697
    Profile photo of P3DCNC
    P3DCNC
    Participant

    Will do that tonight when I get home. Thanks Martin. So when you say “without issues” you mean when you set a plunge feed rate for a bit, that’s what shows up in your gcode? Mine has F500 for all non-travel Z moves.

    #29698
    Profile photo of Martin DB
    Martin DB
    Participant

    Yes my z plunge feerate is what I set in the toolpath screen.

    #29730
    Profile photo of P3DCNC
    P3DCNC
    Participant

    I think I have it figured out @martindb. You are using the “Lead in feed rate” rather than the “plunge feed rate”.

    My understanding is “Lead in” is from the side as it enters the work piece. This is useful to slowly load the bit before accelerating to the cutting feedrate. “Plunge” is from the top down into the material like a drill bit.

    Most of my moves should actually be a plunge, lead in, cut, lead out, travel z, move, travel z, repeat. For the attached tool path anyway.

    See attached.

    #29735
    Profile photo of P3DCNC
    P3DCNC
    Participant

    Thought it might be the RAMP settings. Doesn’t look like it though. See attached.

    #29738
    Profile photo of P3DCNC
    P3DCNC
    Participant

    I’m using Lead In as my plunge right now and it’s working great…fyi.

    It seems the Lead In speed affects the Lead In and Plunge speed btw.

    #29739
    Profile photo of Martin DB
    Martin DB
    Participant

    Yes that is what I suspected… I have to many try and error with z feedrate when rc8 change affected.

    The posts processor use the feedrate that fusion send I don’t choose which feedrate to use in the cutting movements.

    #29742
    Profile photo of P3DCNC
    P3DCNC
    Participant

    I’m using RC7 not RC8 btw..

    #29743
    Profile photo of Martin DB
    Martin DB
    Participant

    I’m in RC8 without issues.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.