X & Y calibration.

This topic contains 5 replies, has 2 voices, and was last updated by  Ryan 3 weeks, 5 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #46419

    mikempcnc
    Participant

    Hi to all!

    I have a Chinese version of mpcnc but i cant calibrate it well.

    I use :

    16 Teeth 2GT Timing Pulley with GT2 Belt 2GT Timing Belt 6mm and nema 17 steppers with EstlCam latest version.

    My problem is that i am getting larger items . What i mean … For ex. Y cut 70mm went 78 and z cut 39 mm went 41

    I know that something is wrong in machine settings in Estlcam  but i can’t find it.

    In the other side z axis is ok.

     

    I want to ask you some help.

    Thanks for your time.
    —————————————–

    [EDIT – ADDITIONAL INFO]

    Drivers: Drv8825 For RAMPS
    Firmware: Latest from here for MPCNC
    Board: Keyestudio MEGA 2560 R3 and RAMPS 1.4

    #46420

    Ryan
    Keymaster

    Chinese version?

    What drivers and what firmware on what board?

    1 user thanked author for this post.
    #46440

    mikempcnc
    Participant

    Hello! I made an edit on my first post with the info . Thank you

    #46459

    Ryan
    Keymaster

    Your axis are moving at two different rates, that should not be possible.

    Try again using a pen to plot something larger at least a 100mm square.

    The information you have given does not point to any problems but you also haven;t actually given much info.

    Try counting the pulley teeth to verify what you have is what you bought. Use this page to verify the movements if you have to, https://www.vicious1.com/assembly/software/

    Is 50mm really 50mm?

     

    #46600

    mikempcnc
    Participant

    i made setup again with estlcam , now works great. ~0 mm in 100mm . Thank you!

     

    #46604

    Ryan
    Keymaster

    Cool, glad to hear it.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.