Z axis catching while running

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Z axis catching while running

This topic contains 42 replies, has 5 voices, and was last updated by  Ryan 1 year, 3 months ago.

Viewing 30 posts - 1 through 30 (of 43 total)
  • Author
    Posts
  • #14376

    pls pls
    Participant

    So i just finally finished the new center parts, and I am getting some catching on the z axis. I have been looking for solutions and nothing works, and I for the life of me don’t understand. The machine will be working fine in manual control, but then, when it is doing a print job, the z axis will not work at all. all i get is this noise( i attached a sound file). I have no idea. any help is appreciated.
    I am using a 23.5mm machine with all pla printed parts.

    Attachments:
    1. bad-sound.m4a
    #14380

    John
    Participant

    try to lube the z threaded rod? might be just enough binding that it’s slipping or skipping… odd… mine made a similar noise during big manual control moves until I lubed it a bit.

    #14381

    Ryan
    Keymaster

    What speed do you have Z-moves set to? Max if you bought it from here is 8.7mm/s.

    #14382

    pls pls
    Participant

    I’m not sure if that z feed rate was in repetier or in marlin, but I have gone over all the settings in the tutorials and made sure to reset marlin to only the files that you provided and it still doesn’t work.

    #14383

    Ryan
    Keymaster

    Are you using the hardware and electronics from here, if not what are you using?

    What is your slic3r z feedrate set at in repetier, or whatever slicer you are using?

    #14384

    pls pls
    Participant

    I am using all your components, and I am using estlcam. just to clarify, i was doing the crown as a drawing, i wasn’t printing anything.

    #14385

    Ryan
    Keymaster

    What are you using as your rapid feed rate, cut feed rate, plunge rate, and did you check the box to put a feed rate in every line.

    #14386

    pls pls
    Participant

    you probably can tell I am a bit of a noob, but where is the feed rate in estlcam?

    #14388

    pls pls
    Participant

    i found the plunge feedrate in the tools list is that what you mean?
    it is set to 20mm

    #14389

    Ryan
    Keymaster

    max is 8.7mm/s

    #14390

    pls pls
    Participant

    it didn’t work 🙁

    #14391

    pls pls
    Participant

    im gonna try just a normal print and see how that goes

    #14392

    pls pls
    Participant

    yeah same thing happens with printing on repetier

    #14393

    Ryan
    Keymaster

    Lets see some pictures, Maybe it’s not put together right.

    #14394

    Ryan
    Keymaster

    Did you try the z axis torture test?

    The part that isn’t making sense is manual moves are generally faster than print and milling moves. If you can move it fine manually it points to bad gcaode.

    #14395

    Ryan
    Keymaster

    You could also double check the voltage of the zaxis pot. Make sure it is between 4.7V-.7V. you can turn it up a bit but no higher than .7V.

    Make sure the whole z axis moves smooth buy hand to make sure there is no binding on the screw.

    #14397

    pls pls
    Participant

    yeah so I did the torture test, I messed with the settings, and I messed with the potentiometer on the driver. now i have the drawing job working, and the problem now occurs on manual control, also, it is only on changes of 10mm, not 1 or 0.1. If this is also not an easy fix, don’t worry about it. I can live without perfect manual control.

    #14399

    Ryan
    Keymaster

    What is the voltage of the pot? Too high is worse than too low, you have to set it with a meter.

    Is the travel smooth the whole way by hand? I think the whole problem is this is not moving as smooth as it should. Is your allthread lock centered in the hole?

    #14401

    pls pls
    Participant

    the travel is completely smooth, and i have tested it a bunch with the new settings and it is still catching, now its on both manual and jobs, and it doesn’t make any sense. I have no idea what it could be. and the lock is centered in the hole

    #14402

    John
    Participant

    You used some lube on the threaded rod? And verified it’s straightness I assume?

    #14403

    pls pls
    Participant

    yup

    #14407

    John
    Participant

    Maybe post a pic of the connection to the stepper… Know if the stepper spins inside the pineapple coupler? Or does it skip steps? Maybe if it’s spinning inside the coupler a bit of superglue may be a solution..

    #14409

    pls pls
    Participant

    i have a video of it trying to make the crown uploading now

    #14412

    pls pls
    Participant
    #14413

    Ryan
    Keymaster

    Those accelerations do not look right, much too fast. check your eeprom and see what they currently are. You can do this with the screen or repetier.

    #14414

    John
    Participant

    I was just thinking it looked much faster than mine is.

    #14415

    Barry
    Participant

    Also, make sure those rubber bands aren’t getting near the bearings.

    #14418

    pls pls
    Participant

    Yeah that did it. I bumped down the feedrates and everything is running smoothly. Thanks you so much everyone for all your help! 🙂

    #14421

    Ryan
    Keymaster

    Feedrates are fine, its the accelerations you need to dial in. You want to control your oscillation that are happening and will break bits if not careful. Did you change the firmware, It comes preset, much slower than this?

    #14435

    pls pls
    Participant

    well I had originally changed the z feed rate to 5 from 8.7, and that did fix it, but if this is not right I will keep fiddling, I have brought down z acceleration to maybe 5 and it didn’t work though, are you sure that it isn’t the feed rates?

Viewing 30 posts - 1 through 30 (of 43 total)

You must be logged in to reply to this topic.