Z-axis losing steps

This topic contains 35 replies, has 13 voices, and was last updated by  Ryan 3 months, 2 weeks ago.

Viewing 30 posts - 1 through 30 (of 36 total)
  • Author
    Posts
  • #7178

    mark leino
    Participant

    Well got the 3d printing worked out pretty good, so decided to try out the dw660. Works great, this this cuts great for its weight and isn’t as loud as it would be, but still pretty loud.

    Anyways, I guess I noticed this when I was printing as well, but it was never an issue during the prints. I did several 3-4 hour prints with no issue, except at the end of the print when it went to raise the nozzle i would hear a “bbbbzzzzz” and the axis would not raise. Worked fine during the prints though. Well about 99% of the time with the router attached it works great, but when running the router, eventually it will try to go up, think it did, then cut down deep into the work piece.

    Axis turns really nice and smooth by hand, only takes one finger to spin it all the way up and all the way down. I can’t seem to recreate the issue with manual jogging, or with the machine doing a dry run. It only does it when its cutting, and of course usually at about 75% completion of the test, about 15 minutes. Still haven’t gotten through an entire test yet.

    So what I’m getting at here, is could this be something that can be changed with the stepper motor settings? Step acceleration? I don’t really know what I’m talking about but I have been trying to do some more learning.

    Also, with text it is backwards… so is that as easy as flipping one of the wire sets that hook to the ramps, either x or y?

    Threw a pic in just for fun.

    Thanks.

    Mark

    #7190

    mark leino
    Participant

    So a little more info. I just took the whole z axis out, cleaned, loosened back lash nut, lubed up rod, made sure everything was lined up and square. Still having same issue, possibly worse now? My lead screw turns very easily by hand.

    It’s skipping going up and down. If I put a little finger tension on rod while its going up and down, it skips worse. Couplers not slipping. About 95% of the time it doesn’t do it. Now I’m starting to wonder if the stepper is bad? Is that even a possibility.

    #7194

    Ryan
    Keymaster

    Easy one first, Flip your x axis plug to fix the mirroring.

    For the Zaxis, check the driver voltage. I ship it at about 0.43V. If it is not at that voltage turn it to that. If it is already there turn it up 0.1v at a time and give it a test. you can turn it up pretty high but eventually the stepper will get hot, and if you go above 0.72V you should put a fan on your ramps board to keep the drivers cool. You can actually turn them all up to get more power if you have active cooling. Little hidden bonus…

    I have a test script you can cut and paste into repetier if you right click on the number buttons in manual control. #2 is a z axis only test. I run these on every board on one of my machines before I ship them.

    To use the scripts just right click on the numbers in the repetier manual control screen and paste the following in spot 1 and 2. Apply, then clock on the number to run it.

    1) All axis – Xand Y back and forth 100mm and the z axis up and down 9mm max.
    G91
    G0 Y100 F11400
    G1 Y-100 F11400
    G1 X100 F15000
    G1 X-100 F15000
    G1 Z9 F20000
    G1 Z-9 F522
    G1 Z1 F2000
    G1 Z-1 F2000
    G1 Z1 F2000
    G1 Z-1 F2000
    G90

    2) Z torture – up and down 30mm , small rapids, repeat 3 times.
    G91
    G1 Z30 F522
    G1 Z-30 F522
    G1 Z3 F522
    G1 Z-3 522
    G1 Z1 F522
    G1 Z-1 F522
    G1 Z30 F522
    G1 Z-30 F522
    G1 Z3 F522
    G1 Z-3 522
    G1 Z1 F522
    G1 Z-1 F522
    G1 Z30 F522
    G1 Z-30 F522
    G1 Z3 F522
    G1 Z-3 522
    G1 Z1 F522
    G1 Z-1 F522
    G90

    #7195

    Jeremy
    Participant

    If your using the standard DW660 mounting bracket I found that if the DW660 is rotated a certain way it hits the bolts. It drove me nuts for a week until I figured it out. Rotate the 660 a little. I attached a couple pictures

    I am now using the universal mounting system so I can swap out between a hot end for 3D printing and my Dw660. I noticed that the universal mount has a little more clearance.

    Just a thought. good luck

    #7201

    karltinsly
    Participant

    Hmm. I had some serious problems with the z axis losing steps early on. This might have been the reason. I now use the universal mount, and since I installed it, I’ve pretty much only been using the laser. I’ll have to give the router another try soon.

    #7245

    mark leino
    Participant

    I will try out the torture test when I get home tonight. Gotta love trying to make the problem worse to find out how to make it better. Is that laser setup pretty easy to get working? Sounds like fun.

    #7271

    karltinsly
    Participant

    I have the JTP laser. Once you get it mounted, it’s pretty much plug and play. Lots of fun.

    #7296

    mark leino
    Participant

    I ran the z-torture about 15 times, just looking and watching every part. I ended up adjusting the driver voltage up to .72v, and it seems to be the best results so far. No missed steps on the last job. It still clunks a little when switching directions, but if its losing steps, its catching up. Before it would sometimes miss a big direction jump, of say 5 mm and be completely off.

    The stepper barely got warm after doing repeated torture tests. As far as the driver, it did get a bit warmer it seemed- but I wasn’t ever really paying attention to it before. My backlash spring is pretty loose now, the lower nut is hanging out of the nut trap but it didn’t seem to cause any issues. I really just made the lead screw a little bit easier to turn.

    Any input on the stepper clunking? It reminds me of the sound of gears not meshing together for a split second. My x and y’s don’t make this noise, but they also spin much slower.

    #7318

    Ryan
    Keymaster

    That doesn’t sound right. Mine are pretty silent unless something is wrong. I know its a pain but maybe switch the z steppers with one of the others. Narrow it down to the steppers or something else.

    #7323

    Ryan
    Keymaster

    So I was testing boards today and got one that just wouldn’t cooperate on the zaxis. I turned the pot up, down, switched drivers, changed the feed rate. Nothing worked.

    The solution was change the zaxis acceleration to 45 instead of 55. That is a bummer, I need to do more testing on this before I release a new firmware, but you might want to try it.

    I would kind of prefer to have the acceleration high and limit the top speed for faster finishing passes on 3d milling. That’s where the testing comes in. I could also start shipping the z axis at 16th stepping if that fixes the issue. I have to get some parts prepped and orders filled before I can spend time testing, just wanted to keep you in the loop.

    #7324

    mark leino
    Participant

    Oh now you tell me, I just switched steppers around! Just kidding it only took about 5 minutes, good trouble shooting test. Still the same issue. Could you give me a quick run down of how to change the acceleration? I haven’t done any previous work with programming or arduino, other than just hooking them up and they work. Thanks for finding a solution!

    #7326

    Ryan
    Keymaster

    Maybe bump the max speed down to 8.5 as well. That really seems to clear it up. I’ll check on the 16th steps tonight or tomorrow. I really want more speed on this axis.

    #8300

    Evan
    Participant

    Having some similar trouble- random missed Z moves on cuts that prevent me from doing anything useful with the machine.

    With the z anti backlash nut backed all the way off, accel turned down to 35 and max speed turned down to 7 I got it to work reliably with the Z torture test. Might be able to handle more than 7, I was just getting frustrated and went very conservative.

    With the anti backlash nut in place (not very tight, hanging halfway out of the nut trap) it still binds and buzzes like crazy. Have adjusted vrefs ranging from .4-.9 without much affect.

    I think maybe the rigid coupler is part of the problem. The first one I printed was way off center, and the one I just redid in an attempt to fix this might still be a little off. I can feel sometimes it is slightly harder to turn the z screw for a little bit.

    #8301

    Ryan
    Keymaster

    There are parametric couplers out there if your printer is not handling my file well. You don’t even need to anti-backlash, it is just for those who want extra protection against zaxis tolerances. Try with out it, especially if it is already backed all the way off, just get it out of the way. Is your z nut holder in line with the coupler? Make sure it isn’t skewed. Lots of little things to check for. If your joiners didn’t print the 45 degree part well it will throw off the alignment. Could be your problem if the couplers aren’t printing well either.

    Make sure your z axis is not twisted as well. Take the whole fully assembled z axis and lay it on a really flat surface like a stone counter or a piece of glass. Make sure both rods are touching nice and flat.

    #9339

    Marco
    Participant

    In order to overcome Ryan’s Z torture test I’ve have to set Vref of Z driver to 0.75V (before was 0.45) and slow max acceleration of Z to 20. Heatsink is almost cold with a 8 cm fan.

    #9412

    Kenny
    Participant

    I have the same problem. When I changed the steps calculation on the z axis to 1/16 instead of 1/32 everything seems to work without stalling. I am using the drv8266 with the three jumpers on board.

    #9505

    Erol
    Participant

    I heard the same sound “bbbbbzzzz” from z motor, I found the solution. please check new topic in software section “estlcam z movement problem”

    #10272

    Jeffeb3
    Participant

    Do I have this same problem? Or Am I fighting something else?

    My Z axis just stops completely, 100% not moving, or making a sound, or resisting me twisting the knob. I was getting it when I was jumping around with my LCD screen, but I just did my first cut of some foam, and it did a few minutes, maybe, and it just stopped moving the Z axis.

    I used estlcam to make the gcode. I set the G00 to G01 in the settings as suggested. I have a 3mm/s plunge rate. The LCD panel says my Vzmax is 8.

    The strangest thing is that I also don’t know what I did to fix this before. I power cycled, waited, etc. This time, the Z didn’t come back. I swapped the cables so the Z motor was being driven by the X driver, and it moved just fine. The driver is cold to the touch. Maybe it finally pooped on me.

    Here’s a quick sample of the gcode, I only see Z with an F180, which is 3mm/s, I think.:

    ;Project vectorlogo1 no drips
    ;Created by Estlcam version 8 build 8.304
    ;Machining time about 12:44:01 AM hours

    G90
    M03 S24000

    ; manually added to set the feed rate first.
    G01 F180

    G01 Z5.0000

    ;No. 1: Pocketing: Cutout 10
    G01 X12.2840 Y28.1858 Z5.0000
    G01 Z0.5000
    G01 Z-1.0000 F180 S24000
    G01 X11.6784 F900
    G01 X11.0004 Y29.6168
    G01 X14.4166
    G01 X13.7053 Y31.0478
    G01 X10.3224
    G01 X9.6444 Y32.4788
    G01 X12.9939
    G01 X12.2826 Y33.9098
    G01 X8.9665
    G01 X8.2885 Y35.3408
    G01 X11.5713
    G01 X10.8579 Y36.7718
    G01 X10.2296
    G01 Z5.0000
    G01 X12.2840 Y28.1858
    G01 Z-0.5000
    G01 Z-2.0000 F180
    G01 X11.6784 F900
    G01 X11.0004 Y29.6168
    G01 X14.4166
    G01 X13.7053 Y31.0478
    G01 X10.3224
    G01 X9.6444 Y32.4788
    G01 X12.9939
    G01 X12.2826 Y33.9098
    G01 X8.9665
    G01 X8.2885 Y35.3408
    G01 X11.5713
    G01 X10.8579 Y36.7718
    G01 X10.2296
    G01 Z5.0000
    G01 X12.2840 Y28.1858
    G01 Z-1.5000
    G01 Z-3.0000 F180
    G01 X11.6784 F900
    G01 X11.0004 Y29.6168
    G01 X14.4166
    G01 X13.7053 Y31.0478
    G01 X10.3224
    G01 X9.6444 Y32.4788
    G01 X12.9939
    G01 X12.2826 Y33.9098
    G01 X8.9665
    G01 X8.2885 Y35.3408
    G01 X11.5713
    G01 X10.8579 Y36.7718
    G01 X10.2296
    G01 Z5.0000

    #10273

    Jeffeb3
    Participant

    Well, it isn’t permanently broken. After making this post, it’s been off long enough to work again. Maybe I should try the torture test.

    #10521

    Jeffeb3
    Participant

    For future folk, the problem I had was the “Anti backlash” nut on way too tight, so the screw wasn’t moving smoothly. I should be very smooth.

    #12351

    Karel
    Participant

    I had this problem as well. The axis moved smooth but still made random strange noises. After seeing Ryan’s solution to turn Z-axis acceleration from 55 to 45, I looked into my configuration. It was still on 100. Moved it down to 45, no issues anymore.

    #22309

    Geoff
    Participant

    Where is the acceleration and voltage set at!

    #22311

    Jeffeb3
    Participant

    Acceleration is in the controller (marlin or grbl). For marlin, you can use the screen to set it, I think, and for grbl, you use the $ commands.

    The voltage is set on the driver itself with a screwdriver. If you got the kit from vicious1.com, then he already set it for you. Careful you don’t just to changing that value without a voltmeter, you can toast the motors with too high of a setting. Some info, although the limits they use in this video are quite high vs. experimentally sound values vicious1 uses:

    #22531

    Brian
    Participant

    Im having this issue. Ive been trying all day to resolve it by varying the stepper voltage (however I knew Ryan had it set correctly when he shipped them).

    Movements with manual control work fine. I want to be sure i’m changing the right values on config.h Are the ones Ive poiinted to the correct ones to lower to 8.5 / 45 ?

    Thanks

    Attachments:
    #22533

    Ryan
    Keymaster

    Why not use my firmware?

    For whatever reason if you don’t want to use my pre-edited one you can open it and see every change I made they are all commented with “MPCNC”.

    #22534

    Brian
    Participant

    I thought I was, but right after the build / setup I could not get anything to move and the LCD was just white boxes. So, I downloaded the B16_32-LCD-112515 and the LCD came to life and the steppers moved.

    **I now see your build with changes**
    I’m learning. Maybe the hard way but learning non the less. I’ll load up your firmware tomorrow and give it a test.

    Thanks.

    #22535

    Ryan
    Keymaster

    You should be using the RC8 now.

    #22603

    Brian
    Participant

    *UPDATE*

    Ryan, I tried installing the RC8 build and running the Z Torture test and it wouldn’t work. It tried to start but stoped right after the start. I then installed the older RC7 and it worked GREAT. I was able to do the hour long engraving (that I tried SO hard to do yesterday) without any issues. *Worked Great* 🙂

    Thanks for your time

    #22607

    Ryan
    Keymaster

    That’s just it, the torture test was purposely too fast on the z axis. So it fails. If you change the speed to the firmware max it works perfectly. I have two MPCNC’s running the rc8 to 3d print since the RC8 release. They work perfectly. It is something with how estlcam is writing it’s code. I have tried turning off all kinds off things in rc8 and I doesn’t fix it, so I updated to rc8 bug fix still nothing. The laser works way better on RC8 because of the LCD fix.

    I am actually not sure if it is estlcam or marlin doing the wrong thing. I am thinking it is something with ESTLCAM. I am digging in now. I even tried an older estlcam and the new experimental. Same result. If the laser works and the 3d printer slicers work it has to be ESTLCAM, right?

    I took the RC8 link down, but every one that I have shipped kits to flashed with RC8 is going to be pissed. if it is a firmware thing.

    #35018

    Dean
    Participant

    I’m dealing with this problem on my new build. I can use the LCD control to move the z-axis up and down without issue, but using a file off of the SD card leads to grinding noises, hesitation and just strange z-axis behavior. I’ve started troubleshooting adjusting voltage on the driver. I’m using the 1.1 firmware offered from the main page for the 5/16 rod.

    I think I’d like to try 1/16th stepping. is that a firmware change or a jumper change? I have the firmware modified to use a laser and that works great with the X and Y axis.

Viewing 30 posts - 1 through 30 (of 36 total)

You must be logged in to reply to this topic.